Skip to content

← Public intelligence

npm package

lodash-amd

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1npmAmendedPublished

    lodash vulnerable to Code Injection via _.template imports key names

    CVE-2026-4800 · GHSA-r5fr-rjxr-66jc

    Affected
    • npm lodash-amd >= 4.0.0, <= 4.17.23
    Fixed in
    4.18.0· Vendor fix available
    Issue
    Impact The fix for CVE-2021-23337 added validation for the variable option in .template but did not apply the same validation to options.imports key names. Both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, .template uses assignInWith to merge imports, which enumerates inherited properties via for..in. If Object.prototype has been polluted by any other vector, the polluted keys are copied into the imports object and passed to Function(). Patches Users should upgrade to version 4.18.0. The fix applies two changes: 1. Validate importsKeys against the existing reForbiddenIdentifierChars regex (same check already used for the variable option) 2. Replace assignInWith with assignWith when merging imports, so only own properties are enumerated Workarounds Do not pass untrusted input as…

    Recommended action: Upgrade to 4.18.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.5npmAmendedPublished

    lodash vulnerable to prototype pollution via array-path bypass in `_.unset`, `_.omit`, and `_.pullAt

    CVE-2026-2950 · GHSA-f23m-r3pf-42rh

    Affected
    • npm lodash-amd >= 4.17.23, < 4.18.1
    Fixed in
    4.18.1· Vendor fix available
    Issue
    Impact The `_.unset`, `_.omit`, and `_.pullAt` functions are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as `Object.prototype`, `Number.prototype`, and `String.prototype`. The issue permits deletion of prototype properties but does not allow overwriting their original behavior. Patches The issue is patched from 4.18.0 to 4.18.1 depending on the package: `lodash`, `lodash-es`, and `lodash-amd` in 4.18.1, and the standalone `lodash.unset` and `lodash.omit` packages in 4.18.0. Workarounds None. Upgrade to the patched version. References - CVE-2025-13465 / GHSA-xxjr-mmjv-4gpg (original fix that this bypasses)

    Recommended action: Upgrade to 4.18.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.9npmAmendedPublished

    Lodash has Prototype Pollution Vulnerability in _.unset, _.omit, and _.pullAt functions

    CVE-2025-13465 · GHSA-xxjr-mmjv-4gpg

    Affected
    • npm lodash-amd >= 4.0.0, < 4.17.23
    Fixed in
    4.17.23· Vendor fix available
    Issue
    Impact The `_.unset`, `_.omit`, and `_.pullAt` functions are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. Patches The issue is patched from 4.17.23 to 4.18.0 depending on the package: `lodash`, `lodash-es`, and `lodash-amd` in 4.17.23, and the standalone `lodash.unset` and `lodash.omit` packages in 4.18.0. Workarounds None. Upgrade to the patched version.

    Recommended action: Upgrade to 4.17.23 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.5npmAmendedPublished

    Regular Expression Denial of Service (ReDoS) in lodash

    CVE-2019-1010266 · GHSA-x5rq-j2xg-h7qm

    Affected
    • npm lodash-amd >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11· Vendor fix available
    Issue
    lodash prior to 4.7.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.7.11.

    Recommended action: Upgrade to 4.17.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Critical, CVSS 9.1npmAmendedPublished

    Prototype Pollution in lodash

    CVE-2019-10744 · GHSA-jf85-cpcp-j695

    Affected
    • npm lodash-amd < 4.17.13
    Fixed in
    4.17.13· Vendor fix available
    Issue
    Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects. Recommendation Update to version 4.17.12 or later.

    Recommended action: Upgrade to 4.17.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →