Skip to content

← Actionable
Medium, CVSS 6.5amended

Regular Expression Denial of Service (ReDoS) in lodash

CVE-2019-1010266GHSA-x5rq-j2xg-h7qm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lodash-rails 4.17.11; lodash-es 4.17.11; lodash 4.17.11; lodash-amd 4.17.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems lodash-rails

    Affected
    >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11
  • npm lodash-es

    Affected
    >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11
  • npm lodash

    Affected
    >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11
  • npm lodash-amd

    Affected
    >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-1010266: 3.04% estimated exploitation activity in the next 30 days; percentile 87.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

lodash prior to 4.7.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.7.11.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x5rq-j2xg-h7qm

  2. Revision 1 · created ·

    Published from osv record GHSA-x5rq-j2xg-h7qm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-1010266

Advisory: Regular Expression Denial of Service (ReDoS) in lodash
IDs: CVE-2019-1010266, GHSA-x5rq-j2xg-h7qm
Record: https://patchnext.com/advisories/cve-2019-1010266 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lodash-rails 4.17.11; lodash-es 4.17.11; lodash 4.17.11; lodash-amd 4.17.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems lodash-rails: affected >= 4.7.0, < 4.17.11; fixed in 4.17.11
- npm lodash-es: affected >= 4.7.0, < 4.17.11; fixed in 4.17.11
- npm lodash: affected >= 4.7.0, < 4.17.11; fixed in 4.17.11
- npm lodash-amd: affected >= 4.7.0, < 4.17.11; fixed in 4.17.11

## Suggested inspection (read-only)
- RubyGems lodash-rails: check the installed version with your package manager.
- `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash-amd --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lodash-rails, lodash-es, lodash, lodash-amd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x5rq-j2xg-h7qm (OSV record GHSA-x5rq-j2xg-h7qm lists affected ranges: npm lodash >=4.7.0 =4.7.0 =4.7.0 =4.7.0 <4.17.11 (fixed))
- Verified: https://github.com/advisories/GHSA-x5rq-j2xg-h7qm (GitHub-reviewed advisory GHSA-x5rq-j2xg-h7qm lists affected ranges: npm lodash >=4.7.0 =4.7.0 =4.7.0 =4.7.0 <4.17.11)

Commands are suggestions: review each one before running it.

Loading voting…