Skip to content

← Public intelligence

RubyGems package

lodash-rails

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5RubyGemsAmendedPublished

    Regular Expression Denial of Service (ReDoS) in lodash

    CVE-2019-1010266 · GHSA-x5rq-j2xg-h7qm

    Affected
    • RubyGems lodash-rails >= 4.7.0, < 4.17.11
    Fixed in
    4.17.11· Vendor fix available
    Issue
    lodash prior to 4.7.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.7.11.

    Recommended action: Upgrade to 4.17.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.1RubyGemsAmendedPublished

    Prototype Pollution in lodash

    CVE-2019-10744 · GHSA-jf85-cpcp-j695

    Affected
    • RubyGems lodash-rails < 4.17.12
    Fixed in
    4.17.12· Vendor fix available
    Issue
    Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects. Recommendation Update to version 4.17.12 or later.

    Recommended action: Upgrade to 4.17.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratedRubyGemsAmendedPublished

    Prototype Pollution in lodash

    CVE-2018-16487 · GHSA-4xc9-xhrj-v574

    Affected
    • RubyGems lodash-rails < 4.17.11
    Fixed in
    4.17.11· Vendor fix available
    Issue
    Versions of lodash before 4.17.11 are vulnerable to prototype pollution. The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects. Recommendation Update to version 4.17.11 or later.

    Recommended action: Upgrade to 4.17.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.5RubyGemsAmendedPublished

    Prototype Pollution in lodash

    CVE-2018-3721 · GHSA-fvqr-27wr-82fm

    Affected
    • RubyGems lodash-rails < 4.17.5
    Fixed in
    4.17.5· Vendor fix available
    Issue
    Versions of lodash before 4.17.5 are vulnerable to prototype pollution. The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of Object via proto causing the addition or modification of an existing property that will exist on all objects. Recommendation Update to version 4.17.5 or later.

    Recommended action: Upgrade to 4.17.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →