Prototype Pollution in lodash
CVE-2019-10744GHSA-jf85-cpcp-j695
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lodash.defaultsdeep 4.6.1; lodash-rails 4.17.12; lodash-es 4.17.14; lodash 4.17.12; lodash-amd 4.17.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.6.1
- Fixed in
- 4.6.1
RubyGems lodash-rails
- Affected
- < 4.17.12
- Fixed in
- 4.17.12
npm lodash-es
- Affected
- < 4.17.14
- Fixed in
- 4.17.14
npm lodash
- Affected
- < 4.17.12
- Fixed in
- 4.17.12
npm lodash-amd
- Affected
- < 4.17.13
- Fixed in
- 4.17.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jf85-cpcp-j695 lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf85-cpcp-j695 lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2019-10744: 5.01% estimated exploitation activity in the next 30 days; percentile 92.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects. Recommendation Update to version 4.17.12 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jf85-cpcp-j695
- Revision 1 · created ·
Published from osv record GHSA-jf85-cpcp-j695
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10744 Advisory: Prototype Pollution in lodash IDs: CVE-2019-10744, GHSA-jf85-cpcp-j695 Record: https://patchnext.com/advisories/cve-2019-10744 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lodash.defaultsdeep 4.6.1; lodash-rails 4.17.12; lodash-es 4.17.14; lodash 4.17.12; lodash-amd 4.17.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm lodash.defaultsdeep: affected < 4.6.1; fixed in 4.6.1 - RubyGems lodash-rails: affected < 4.17.12; fixed in 4.17.12 - npm lodash-es: affected < 4.17.14; fixed in 4.17.14 - npm lodash: affected < 4.17.12; fixed in 4.17.12 - npm lodash-amd: affected < 4.17.13; fixed in 4.17.13 ## Suggested inspection (read-only) - `npm ls lodash.defaultsdeep --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - RubyGems lodash-rails: check the installed version with your package manager. - `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash-amd --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lodash.defaultsdeep, lodash-rails, lodash-es, lodash, lodash-amd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jf85-cpcp-j695 (OSV record GHSA-jf85-cpcp-j695 lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.12 (fixed)) - Verified: https://github.com/advisories/GHSA-jf85-cpcp-j695 (GitHub-reviewed advisory GHSA-jf85-cpcp-j695 lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.12) Commands are suggestions: review each one before running it.
Loading voting…