Skip to content

← Actionable
Medium, CVSS 6.5amended

lodash vulnerable to prototype pollution via array-path bypass in `_.unset`, `_.omit`, and `_.pullAt

CVE-2026-2950GHSA-f23m-r3pf-42rh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lodash.omit 4.18.0; lodash.unset 4.18.0; lodash-es 4.18.1; lodash 4.18.1; lodash-amd 4.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm lodash.omit

    Affected
    < 4.18.0
    Fixed in
    4.18.0
  • npm lodash.unset

    Affected
    < 4.18.0
    Fixed in
    4.18.0
  • npm lodash-es

    Affected
    >= 4.17.23, < 4.18.1
    Fixed in
    4.18.1
  • npm lodash

    Affected
    >= 4.17.23, < 4.18.1
    Fixed in
    4.18.1
  • npm lodash-amd

    Affected
    >= 4.17.23, < 4.18.1
    Fixed in
    4.18.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2026-2950: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The `_.unset`, `_.omit`, and `_.pullAt` functions are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as `Object.prototype`, `Number.prototype`, and `String.prototype`. The issue permits deletion of prototype properties but does not allow overwriting their original behavior.

Patches The issue is patched from 4.18.0 to 4.18.1 depending on the package: `lodash`, `lodash-es`, and `lodash-amd` in 4.18.1, and the standalone `lodash.unset` and `lodash.omit` packages in 4.18.0.

Workarounds None. Upgrade to the patched version.

References - CVE-2025-13465 / GHSA-xxjr-mmjv-4gpg (original fix that this bypasses)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-f23m-r3pf-42rh

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-f23m-r3pf-42rh

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-f23m-r3pf-42rh

  4. Revision 1 · created ·

    Published from osv record GHSA-f23m-r3pf-42rh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2950

Advisory: lodash vulnerable to prototype pollution via array-path bypass in `_.unset`, `_.omit`, and `_.pullAt
IDs: CVE-2026-2950, GHSA-f23m-r3pf-42rh
Record: https://patchnext.com/advisories/cve-2026-2950 (revision 4, source checked 4 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lodash.omit 4.18.0; lodash.unset 4.18.0; lodash-es 4.18.1; lodash 4.18.1; lodash-amd 4.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm lodash.omit: affected < 4.18.0; fixed in 4.18.0
- npm lodash.unset: affected < 4.18.0; fixed in 4.18.0
- npm lodash-es: affected >= 4.17.23, < 4.18.1; fixed in 4.18.1
- npm lodash: affected >= 4.17.23, < 4.18.1; fixed in 4.18.1
- npm lodash-amd: affected >= 4.17.23, < 4.18.1; fixed in 4.18.1

## Suggested inspection (read-only)
- `npm ls lodash.omit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash.unset --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash-amd --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lodash.omit, lodash.unset, lodash-es, lodash, lodash-amd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f23m-r3pf-42rh (OSV record GHSA-f23m-r3pf-42rh lists affected ranges: npm lodash >=0 =0 =0 =4.0.0 <4.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f23m-r3pf-42rh (GitHub-reviewed advisory GHSA-f23m-r3pf-42rh lists affected ranges: npm lodash >=0 =0 =0 =4.0.0 <4.18.0)
- Verified: https://github.com/advisories/GHSA-f23m-r3pf-42rh (GitHub-reviewed advisory GHSA-f23m-r3pf-42rh lists affected ranges: npm lodash >=4.17.23 =4.17.23 =4.17.23 =0 =0 <4.18.0)
- Verified: https://osv.dev/vulnerability/GHSA-f23m-r3pf-42rh (OSV record GHSA-f23m-r3pf-42rh lists affected ranges: npm lodash >=4.17.23 =4.17.23 =4.17.23 =0 =0 <4.18.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…