Skip to content

← Public intelligence

npm package

@excalidraw/excalidraw

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Excalidraw vulnerable to XSS via Mermaid sequence diagram labels (KaTeX rendering)

    GHSA-39h7-pwv7-rc3x

    Affected
    • npm @excalidraw/excalidraw >= 0.18.0, <= 0.18.0
    Fixed in
    0.18.1· Vendor fix available
    Issue
    Impact @excalidraw/excalidraw@0.18.0 depends on a Mermaid conversion package version that resolves to a Mermaid release affected by CVE-2025-54881 / GHSA-7rqq-prvp-x9jh. User-supplied Mermaid sequence diagram labels could trigger XSS through Mermaid’s KaTeX label rendering path. This is patched in @excalidraw/excalidraw@0.18.1 by updating @excalidraw/mermaid-to-excalidraw to 2.2.2, which uses a patched Mermaid 11 release. Moderate severity as this XSS requires manual user action - pasting unsafe Mermaid diagram into the Excalidraw editor. No semi-automated attack vector exists by default (such as accessing a link). Patches - Stable @excalidraw/excalidraw@0.18.1 is patched. - Unstable @excalidraw/excalidraw@next has resolved to patched builds since @excalidraw/excalidraw@0.18.0-f29edf on 2025-08-21. - Direct consumers of @excalidraw/mermaid-to-excalidraw should use 1.1.3 or later. Workarounds None. Resources - Upstream Mermaid advisory:…

    Recommended action: Upgrade to 0.18.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Stored Cross-site Scripting (XSS) in excalidraw's web embed component

    CVE-2024-32472 · GHSA-m64q-4jqh-f72f

    Affected
    • npm @excalidraw/excalidraw >= 0.16.0, < 0.16.4; >= 0.17.0, < 0.17.6
    Fixed in
    0.17.60.16.4· Vendor fix available
    Issue
    A stored XSS vulnerability in Excalidraw's web embeddable component. This allows arbitrary JavaScript to be run in the context of the domain where the editor is hosted. Poc Inserting an embed with the below url (can be copy/pasted onto canvas to insert as embed) will log 42 to the console: Details There were two vectors. One rendering untrusted string as iframe's srcdoc without properly sanitizing against HTML injection. Second by improperly sanitizing against attribute HTML injection. This in conjunction with allowing allow-same-origin sandbox flag (necessary for several embeds) resulted in the XSS. Former was fixed by no longer rendering unsafe srcdoc content verbatim, and instead strictly parsing the supplied content and constructing the srcdoc manually. The latter by sanitizing properly. The allow-same-origin flag is now also set only in cases that require it, following the principle of least privilege. Impact This is a cross site scripting vulnerability, for more…

    Recommended action: Upgrade to 0.17.6 or 0.16.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    @excalidraw/excalidraw Cross-site Scripting vulnerability

    CVE-2023-26140 · GHSA-v7v8-gjv7-ffmr

    Affected
    • npm @excalidraw/excalidraw < 0.15.3
    Fixed in
    0.15.3· Vendor fix available
    Issue
    Impact XSS vulnerability due to improperly sanitizing URLs of links that can be attached on canvas elements. This affects users of the npm package @excalidraw/excalidraw provided it was deployed in environments where untrusted user input in drawings that are then shared with third parties is a concern. If you only hosted the editor in trusted environments, or sharing didn't take place, the impact is minimized. Patches Patch is available on version 0.15.3 and up (stable), or latest @excalidraw/excalidraw@next (unstable releases). Workarounds No workaround without upgrading unless deployed in environments without untrusted user input. References https://security.snyk.io/vuln/SNYK-JS-EXCALIDRAWEXCALIDRAW-5841658 https://github.com/excalidraw/excalidraw/pull/6728

    Recommended action: Upgrade to 0.15.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →