Skip to content

← Actionable
Medium, CVSS 6.1amended

Stored Cross-site Scripting (XSS) in excalidraw's web embed component

CVE-2024-32472GHSA-m64q-4jqh-f72f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@excalidraw/excalidraw 0.17.6, 0.16.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-32472: 0.56% estimated exploitation activity in the next 30 days; percentile 46.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored XSS vulnerability in Excalidraw's web embeddable component. This allows arbitrary JavaScript to be run in the context of the domain where the editor is hosted. Poc Inserting an embed with the below url (can be copy/pasted onto canvas to insert as embed) will log 42 to the console: Details There were two vectors. One rendering untrusted string as iframe's srcdoc without properly sanitizing against HTML injection. Second by improperly sanitizing against attribute HTML injection. This in conjunction with allowing allow-same-origin sandbox flag (necessary for several embeds) resulted in the XSS. Former was fixed by no longer rendering unsafe srcdoc content verbatim, and instead strictly parsing the supplied content and constructing the srcdoc manually. The latter by sanitizing properly. The allow-same-origin flag is now also set only in cases that require it, following the principle of least privilege. Impact This is a cross site scripting vulnerability, for more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m64q-4jqh-f72f

  2. Revision 1 · created ·

    Published from osv record GHSA-m64q-4jqh-f72f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32472

Advisory: Stored Cross-site Scripting (XSS) in excalidraw's web embed component
IDs: CVE-2024-32472, GHSA-m64q-4jqh-f72f
Record: https://patchnext.com/advisories/cve-2024-32472 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @excalidraw/excalidraw 0.17.6, 0.16.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @excalidraw/excalidraw: affected >= 0.16.0, < 0.16.4; >= 0.17.0, < 0.17.6; fixed in 0.17.6, 0.16.4

## Suggested inspection (read-only)
- `npm ls @excalidraw/excalidraw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @excalidraw/excalidraw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m64q-4jqh-f72f (OSV record GHSA-m64q-4jqh-f72f lists affected ranges: npm @excalidraw/excalidraw >=0.16.0 =0.17.0 <0.17.6 (fixed))
- Verified: https://github.com/advisories/GHSA-m64q-4jqh-f72f (GitHub-reviewed advisory GHSA-m64q-4jqh-f72f lists affected ranges: npm @excalidraw/excalidraw >=0.16.0 =0.17.0 <0.17.6)

Commands are suggestions: review each one before running it.

Loading voting…