@excalidraw/excalidraw Cross-site Scripting vulnerability
CVE-2023-26140GHSA-v7v8-gjv7-ffmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@excalidraw/excalidraw 0.15.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.15.3
- Fixed in
- 0.15.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v7v8-gjv7-ffmr lists affected ranges: npm @excalidraw/excalidraw >=0 <0.15.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7v8-gjv7-ffmr lists affected ranges: npm @excalidraw/excalidraw >=0 <0.15.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-26140: 0.56% estimated exploitation activity in the next 30 days; percentile 46.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact XSS vulnerability due to improperly sanitizing URLs of links that can be attached on canvas elements. This affects users of the npm package @excalidraw/excalidraw provided it was deployed in environments where untrusted user input in drawings that are then shared with third parties is a concern. If you only hosted the editor in trusted environments, or sharing didn't take place, the impact is minimized. Patches Patch is available on version 0.15.3 and up (stable), or latest @excalidraw/excalidraw@next (unstable releases). Workarounds No workaround without upgrading unless deployed in environments without untrusted user input. References https://security.snyk.io/vuln/SNYK-JS-EXCALIDRAWEXCALIDRAW-5841658 https://github.com/excalidraw/excalidraw/pull/6728
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v7v8-gjv7-ffmr
- Revision 1 · created ·
Published from osv record GHSA-v7v8-gjv7-ffmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26140 Advisory: @excalidraw/excalidraw Cross-site Scripting vulnerability IDs: CVE-2023-26140, GHSA-v7v8-gjv7-ffmr Record: https://patchnext.com/advisories/cve-2023-26140 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @excalidraw/excalidraw 0.15.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @excalidraw/excalidraw: affected < 0.15.3; fixed in 0.15.3 ## Suggested inspection (read-only) - `npm ls @excalidraw/excalidraw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @excalidraw/excalidraw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v7v8-gjv7-ffmr (OSV record GHSA-v7v8-gjv7-ffmr lists affected ranges: npm @excalidraw/excalidraw >=0 <0.15.3 (fixed)) - Verified: https://github.com/advisories/GHSA-v7v8-gjv7-ffmr (GitHub-reviewed advisory GHSA-v7v8-gjv7-ffmr lists affected ranges: npm @excalidraw/excalidraw >=0 <0.15.3) Commands are suggestions: review each one before running it.
Loading voting…