Excalidraw vulnerable to XSS via Mermaid sequence diagram labels (KaTeX rendering)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@excalidraw/mermaid-to-excalidraw 1.1.3; @excalidraw/excalidraw 0.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @excalidraw/mermaid-to-excalidraw
- Affected
- >= 0.3.0, < 1.1.3
- Fixed in
- 1.1.3
- Affected
- >= 0.18.0, <= 0.18.0
- Fixed in
- 0.18.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-39h7-pwv7-rc3x lists affected ranges: npm @excalidraw/excalidraw >=0.18.0 =0.3.0 <1.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-39h7-pwv7-rc3x lists affected ranges: npm @excalidraw/excalidraw >=0.18.0 =0.3.0 <1.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact @excalidraw/excalidraw@0.18.0 depends on a Mermaid conversion package version that resolves to a Mermaid release affected by CVE-2025-54881 / GHSA-7rqq-prvp-x9jh. User-supplied Mermaid sequence diagram labels could trigger XSS through Mermaid’s KaTeX label rendering path. This is patched in @excalidraw/excalidraw@0.18.1 by updating @excalidraw/mermaid-to-excalidraw to 2.2.2, which uses a patched Mermaid 11 release. Moderate severity as this XSS requires manual user action - pasting unsafe Mermaid diagram into the Excalidraw editor. No semi-automated attack vector exists by default (such as accessing a link). Patches - Stable @excalidraw/excalidraw@0.18.1 is patched. - Unstable @excalidraw/excalidraw@next has resolved to patched builds since @excalidraw/excalidraw@0.18.0-f29edf on 2025-08-21. - Direct consumers of @excalidraw/mermaid-to-excalidraw should use 1.1.3 or later. Workarounds None. Resources - Upstream Mermaid advisory:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-39h7-pwv7-rc3x
- Revision 1 · created ·
Published from osv record GHSA-39h7-pwv7-rc3x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-39h7-pwv7-rc3x Advisory: Excalidraw vulnerable to XSS via Mermaid sequence diagram labels (KaTeX rendering) IDs: GHSA-39h7-pwv7-rc3x Record: https://patchnext.com/advisories/ghsa-39h7-pwv7-rc3x (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @excalidraw/mermaid-to-excalidraw 1.1.3; @excalidraw/excalidraw 0.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @excalidraw/mermaid-to-excalidraw: affected >= 0.3.0, < 1.1.3; fixed in 1.1.3 - npm @excalidraw/excalidraw: affected >= 0.18.0, <= 0.18.0; fixed in 0.18.1 ## Suggested inspection (read-only) - `npm ls @excalidraw/mermaid-to-excalidraw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @excalidraw/excalidraw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @excalidraw/mermaid-to-excalidraw, @excalidraw/excalidraw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-39h7-pwv7-rc3x (OSV record GHSA-39h7-pwv7-rc3x lists affected ranges: npm @excalidraw/excalidraw >=0.18.0 =0.3.0 <1.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-39h7-pwv7-rc3x (GitHub-reviewed advisory GHSA-39h7-pwv7-rc3x lists affected ranges: npm @excalidraw/excalidraw >=0.18.0 =0.3.0 <1.1.3) Commands are suggestions: review each one before running it.
Loading voting…