Skip to content

← Public intelligence

PyPI package

tlslite-ng

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    RSA weakness in tslite-ng

    CVE-2020-26263 · GHSA-wvcv-832q-fjg7

    Affected
    • PyPI tlslite-ng < 0.7.6
    Fixed in
    0.7.6· Vendor fix available
    Issue
    Impact The code that performs decryption and padding check in RSA PKCS#1 v1.5 decryption is data dependant. In particular, code in current (as of 0.8.0-alpha38) master https://github.com/tlsfuzzer/tlslite-ng/blob/0812ed60860fa61a6573b2c0e18771414958f46d/tlslite/utils/rsakey.py#L407-L441 and code in 0.7.5 branch https://github.com/tlsfuzzer/tlslite-ng/blob/acdde3161124d6ae37c506b3476aea9996d12e97/tlslite/utils/rsakey.py#L394-L425 has multiple ways in which it leaks information (for one, it aborts as soon as the plaintext doesn't start with 0x00, 0x02) about the decrypted ciphertext (both the bit length of the decrypted message as well as where the first unexpected byte lays). All TLS servers that enable RSA key exchange as well as applications that use the RSA decryption API directly are vulnerable. All previous versions of tlslite-ng are vulnerable. Patches The patches to fix it are proposed in https://github.com/tlsfuzzer/tlslite-ng/pull/438…

    Recommended action: Upgrade to 0.7.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.2PyPIAmendedPublished

    tlslite-ng off-by-one error on mac checking

    CVE-2018-1000159 · GHSA-cwh5-3cw7-4286

    Affected
    • PyPI tlslite-ng < 0.7.4
    Fixed in
    0.7.4· Vendor fix available
    Issue
    tlslite-ng version 0.7.3 and earlier, since commit d7b288316bca7bcdd082e6ccff5491e241305233 contains a CWE-354: Improper Validation of Integrity Check Value vulnerability in TLS implementation, tlslite/utils/constanttime.py: ctcheckcbcmacandpad(); line endpos = datalen - 1 - mac.digestsize that can result in an attacker manipulating the TLS ciphertext which will not be detected by receiving tlslite-ng. This attack appears to be exploitable via man in the middle on a network connection. This vulnerability appears to have been fixed after commit 3674815d1b0f7484454995e2737a352e0a6a93d8.

    Recommended action: Upgrade to 0.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →