RSA weakness in tslite-ng
CVE-2020-26263GHSA-wvcv-832q-fjg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tlslite-ng 0.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tlslite-ng
- Affected
- < 0.7.6
- Fixed in
- 0.7.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvcv-832q-fjg7 lists affected ranges: PyPI tlslite-ng >=0 <0.7.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvcv-832q-fjg7 lists affected ranges: PyPI tlslite-ng >=0 <0.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-26263: 1.52% estimated exploitation activity in the next 30 days; percentile 74.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The code that performs decryption and padding check in RSA PKCS#1 v1.5 decryption is data dependant. In particular, code in current (as of 0.8.0-alpha38) master https://github.com/tlsfuzzer/tlslite-ng/blob/0812ed60860fa61a6573b2c0e18771414958f46d/tlslite/utils/rsakey.py#L407-L441 and code in 0.7.5 branch https://github.com/tlsfuzzer/tlslite-ng/blob/acdde3161124d6ae37c506b3476aea9996d12e97/tlslite/utils/rsakey.py#L394-L425 has multiple ways in which it leaks information (for one, it aborts as soon as the plaintext doesn't start with 0x00, 0x02) about the decrypted ciphertext (both the bit length of the decrypted message as well as where the first unexpected byte lays). All TLS servers that enable RSA key exchange as well as applications that use the RSA decryption API directly are vulnerable. All previous versions of tlslite-ng are vulnerable. Patches The patches to fix it are proposed in https://github.com/tlsfuzzer/tlslite-ng/pull/438…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wvcv-832q-fjg7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wvcv-832q-fjg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26263 Advisory: RSA weakness in tslite-ng IDs: CVE-2020-26263, GHSA-wvcv-832q-fjg7 Record: https://patchnext.com/advisories/cve-2020-26263 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tlslite-ng 0.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tlslite-ng: affected < 0.7.6; fixed in 0.7.6 ## Suggested inspection (read-only) - `python -m pip show tlslite-ng`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tlslite-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvcv-832q-fjg7 (OSV record GHSA-wvcv-832q-fjg7 lists affected ranges: PyPI tlslite-ng >=0 <0.7.6 (fixed)) - Verified: https://github.com/advisories/GHSA-wvcv-832q-fjg7 (GitHub-reviewed advisory GHSA-wvcv-832q-fjg7 lists affected ranges: PyPI tlslite-ng >=0 <0.7.6) Commands are suggestions: review each one before running it.
Loading voting…