Skip to content

← Actionable
High, CVSS 8.2amended

tlslite-ng off-by-one error on mac checking

CVE-2018-1000159GHSA-cwh5-3cw7-4286

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tlslite-ng 0.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2018-1000159: 0.77% estimated exploitation activity in the next 30 days; percentile 55.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

tlslite-ng version 0.7.3 and earlier, since commit d7b288316bca7bcdd082e6ccff5491e241305233 contains a CWE-354: Improper Validation of Integrity Check Value vulnerability in TLS implementation, tlslite/utils/constanttime.py: ctcheckcbcmacandpad(); line endpos = datalen - 1 - mac.digestsize that can result in an attacker manipulating the TLS ciphertext which will not be detected by receiving tlslite-ng. This attack appears to be exploitable via man in the middle on a network connection. This vulnerability appears to have been fixed after commit 3674815d1b0f7484454995e2737a352e0a6a93d8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cwh5-3cw7-4286

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cwh5-3cw7-4286

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000159

Advisory: tlslite-ng off-by-one error on mac checking
IDs: CVE-2018-1000159, GHSA-cwh5-3cw7-4286
Record: https://patchnext.com/advisories/cve-2018-1000159 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tlslite-ng 0.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tlslite-ng: affected < 0.7.4; fixed in 0.7.4

## Suggested inspection (read-only)
- `python -m pip show tlslite-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tlslite-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cwh5-3cw7-4286 (OSV record GHSA-cwh5-3cw7-4286 lists affected ranges: PyPI tlslite-ng >=0 <0.7.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cwh5-3cw7-4286 (GitHub-reviewed advisory GHSA-cwh5-3cw7-4286 lists affected ranges: PyPI tlslite-ng >=0 <0.7.4)

Commands are suggestions: review each one before running it.

Loading voting…