Skip to content

← Public intelligence

PyPI package

pretalx

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    pretalx vulnerable to stored cross-site scripting in organizer search typeahead

    CVE-2026-41241 · GHSA-cjcx-jfp2-f7m2

    Affected
    • PyPI pretalx < 2026.1.0
    Fixed in
    2026.1.0· Vendor fix available
    Issue
    The organiser search in the pretalx backend rendered submission titles, speaker display names, and user names/emails into the result dropdown using innerHTML string interpolation. Any user who controls one of those fields (which includes any registered user whose display name is looked up by an administrator) could include HTML or JavaScript that would execute in an organiser's browser when the organiser's search query matched the malicious record. Triggering the vulnerability required: 1. An attacker-controlled field reachable by the search, which included any speaker's or submitter's display name in an event context (submitted a proposal) or any user at all for superusers. 2. An organiser user with more than just review permissions or administrator user performing a typeahead search whose query matched the malicious record. An attacker can make matches likely by placing common substrings in the payload-bearing field. Once triggered, the injected script executed in the context of…

    Recommended action: Upgrade to 2026.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1PyPIAmendedPublished

    pretalx mail templates vulnerable to email injection via unescaped user-controlled placeholders

    CVE-2026-41426 · GHSA-jm8c-9f3j-4378

    Affected
    • PyPI pretalx < 2026.1.0
    Fixed in
    2026.1.0· Vendor fix available
    Issue
    An unauthenticated attacker can send arbitrary HTML-rendered emails from a pretalx instance's configured sender address by embedding malformed HTML or markdown link syntax in a user-controlled template placeholder such as the account display name. The most direct vector is the password-reset flow: the attacker registers an account with a malicious name, enters the victim's email address, and triggers a password reset. The resulting email is delivered from the event's legitimate sender address and passes SPF/DKIM/DMARC validation, making it a ready-made phishing vector. The same class of bug affects every mail template that interpolates a user-controlled placeholder (speaker name, proposal title, biography, question answers, etc.), including organiser-triggered emails such as acceptance/rejection notifications. Credits Thanks go to Mark Fijneman for finding and reporting a subset of this issue, which alerted us to the wider vulnerability.

    Recommended action: Upgrade to 2026.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.1PyPIAmendedPublished

    pretalx vulnerable to path traversal in HTML export

    CVE-2023-28459 · GHSA-wh3w-jcc7-mhmf

    Affected
    • PyPI pretalx < 2.3.2
    Fixed in
    2.3.2· Vendor fix available
    Issue
    pretalx before 2.3.2 allows path traversal in HTML export (a non-default feature). Users were able to upload crafted HTML documents that trigger the reading of arbitrary files.

    Recommended action: Upgrade to 2.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.3PyPIAmendedPublished

    pretalx allows path traversal in HTML export

    CVE-2023-28458 · GHSA-23fx-92m6-4f2g

    Affected
    • PyPI pretalx >= 2.3.1, < 2.3.2
    Fixed in
    2.3.2· Vendor fix available
    Issue
    pretalx 2.3.1 before 2.3.2 allows path traversal in HTML export (a non-default feature). Organizers can trigger the overwriting (with the standard pretalx 404 page content) of an arbitrary file.

    Recommended action: Upgrade to 2.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →