pretalx mail templates vulnerable to email injection via unescaped user-controlled placeholders
CVE-2026-41426GHSA-jm8c-9f3j-4378
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretalx 2026.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretalx
- Affected
- < 2026.1.0
- Fixed in
- 2026.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jm8c-9f3j-4378 lists affected ranges: PyPI pretalx >=0 <2026.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jm8c-9f3j-4378 lists affected ranges: PyPI pretalx >=0 <2026.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-41426: 0.15% estimated exploitation activity in the next 30 days; percentile 4.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An unauthenticated attacker can send arbitrary HTML-rendered emails from a pretalx instance's configured sender address by embedding malformed HTML or markdown link syntax in a user-controlled template placeholder such as the account display name. The most direct vector is the password-reset flow: the attacker registers an account with a malicious name, enters the victim's email address, and triggers a password reset. The resulting email is delivered from the event's legitimate sender address and passes SPF/DKIM/DMARC validation, making it a ready-made phishing vector. The same class of bug affects every mail template that interpolates a user-controlled placeholder (speaker name, proposal title, biography, question answers, etc.), including organiser-triggered emails such as acceptance/rejection notifications. Credits Thanks go to Mark Fijneman for finding and reporting a subset of this issue, which alerted us to the wider vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jm8c-9f3j-4378
- Revision 1 · created ·
Published from osv record GHSA-jm8c-9f3j-4378
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41426 Advisory: pretalx mail templates vulnerable to email injection via unescaped user-controlled placeholders IDs: CVE-2026-41426, GHSA-jm8c-9f3j-4378 Record: https://patchnext.com/advisories/cve-2026-41426 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretalx 2026.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretalx: affected < 2026.1.0; fixed in 2026.1.0 ## Suggested inspection (read-only) - `python -m pip show pretalx`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretalx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jm8c-9f3j-4378 (OSV record GHSA-jm8c-9f3j-4378 lists affected ranges: PyPI pretalx >=0 <2026.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jm8c-9f3j-4378 (GitHub-reviewed advisory GHSA-jm8c-9f3j-4378 lists affected ranges: PyPI pretalx >=0 <2026.1.0) Commands are suggestions: review each one before running it.
Loading voting…