pretalx vulnerable to stored cross-site scripting in organizer search typeahead
CVE-2026-41241GHSA-cjcx-jfp2-f7m2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretalx 2026.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretalx
- Affected
- < 2026.1.0
- Fixed in
- 2026.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cjcx-jfp2-f7m2 lists affected ranges: PyPI pretalx >=0 <2026.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cjcx-jfp2-f7m2 lists affected ranges: PyPI pretalx >=0 <2026.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-41241: 0.17% estimated exploitation activity in the next 30 days; percentile 5.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The organiser search in the pretalx backend rendered submission titles, speaker display names, and user names/emails into the result dropdown using innerHTML string interpolation. Any user who controls one of those fields (which includes any registered user whose display name is looked up by an administrator) could include HTML or JavaScript that would execute in an organiser's browser when the organiser's search query matched the malicious record. Triggering the vulnerability required: 1. An attacker-controlled field reachable by the search, which included any speaker's or submitter's display name in an event context (submitted a proposal) or any user at all for superusers. 2. An organiser user with more than just review permissions or administrator user performing a typeahead search whose query matched the malicious record. An attacker can make matches likely by placing common substrings in the payload-bearing field. Once triggered, the injected script executed in the context of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cjcx-jfp2-f7m2
- Revision 1 · created ·
Published from osv record GHSA-cjcx-jfp2-f7m2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41241 Advisory: pretalx vulnerable to stored cross-site scripting in organizer search typeahead IDs: CVE-2026-41241, GHSA-cjcx-jfp2-f7m2 Record: https://patchnext.com/advisories/cve-2026-41241 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretalx 2026.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretalx: affected < 2026.1.0; fixed in 2026.1.0 ## Suggested inspection (read-only) - `python -m pip show pretalx`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretalx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cjcx-jfp2-f7m2 (OSV record GHSA-cjcx-jfp2-f7m2 lists affected ranges: PyPI pretalx >=0 <2026.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cjcx-jfp2-f7m2 (GitHub-reviewed advisory GHSA-cjcx-jfp2-f7m2 lists affected ranges: PyPI pretalx >=0 <2026.1.0) Commands are suggestions: review each one before running it.
Loading voting…