Skip to content

← Public intelligence

PyPI package

nemo-toolkit

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8PyPIAmendedPublished

    NVIDIA NeMo Framework contains a vulnerability leading to Remote Code Execution

    CVE-2026-24159 · GHSA-v7v2-m736-cf3c

    Affected
    • PyPI nemo-toolkit < 2.6.2
    Fixed in
    2.6.2· Vendor fix available
    Issue
    NVIDIA NeMo Framework contains a vulnerability where an attacker may cause remote code execution. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, information disclosure and data tampering.

    Recommended action: Upgrade to 2.6.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.8PyPIAmendedPublished

    NVIDIA NeMo Framework contains an RCE vulnerability in checkpoint loading

    CVE-2026-24157 · GHSA-m4jw-wgmf-889x

    Affected
    • PyPI nemo-toolkit < 2.6.2
    Fixed in
    2.6.2· Vendor fix available
    Issue
    NVIDIA NeMo Framework contains a vulnerability in checkpoint loading where an attacker could cause remote code execution. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, information disclosure and data tampering.

    Recommended action: Upgrade to 2.6.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.8PyPIAmendedPublished

    NVIDIA NeMo Framework Deserializes Untrusted Data

    CVE-2025-33253 · GHSA-hvjw-vp7g-39h5

    Affected
    • PyPI nemo-toolkit < 2.6.1
    Fixed in
    2.6.1· Vendor fix available
    Issue
    NVIDIA NeMo Framework contains a vulnerability where an attacker could cause remote code execution by convincing a user to load a maliciously crafted file. A successful exploit of this vulnerability might lead to code execution, denial of service, information disclosure, and data tampering.

    Recommended action: Upgrade to 2.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.0PyPIAmendedPublished

    NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution

    CVE-2025-33245 · GHSA-9379-mwvr-7wxx

    Affected
    • PyPI nemo-toolkit < 2.6.1
    Fixed in
    2.6.1· Vendor fix available
    Issue
    NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, information disclosure, and data tampering.

    Recommended action: Upgrade to 2.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Low, CVSS 2.0PyPIAmendedPublished

    Arbitrary file deletion in NeMo ASR webapp

    CVE-2022-22821 · GHSA-9hg3-hmmf-c3gr

    Affected
    • PyPI nemo-toolkit < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    NVIDIA NeMo contains a vulnerability in ASR WebApp, where Relative Path Traversal (CWE-23) may lead to deletion of any directory through the "../" structure when admin privileges are available. CVSS Score = 2.0 https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N Impact When the optional tool ASR Webapp (https://github.com/NVIDIA/NeMo/tree/main/tools/asrwebapp) is used prior to commit https://github.com/NVIDIA/NeMo/commit/f7e4ed7e4f7f2fa43765a38c2fafa1b6d1ebd7c0, some interfaces do not verify user input. Malicious attackers can construct malicious requests to delete any directory through the "../" structure. The vulnerability affects only cases where this particular web app is started by a user with superuser permissions. The web application is not a part of the regular pip release or the corresponding container, and impacts only users that clone the repository in its entirety and execute the web app (while also possessing…

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →