Arbitrary file deletion in NeMo ASR webapp
CVE-2022-22821GHSA-9hg3-hmmf-c3gr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nemo-toolkit 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nemo-toolkit
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9hg3-hmmf-c3gr lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rpx7-33j2-xx9x lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rpx7-33j2-xx9x lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.0 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-22821: 0.31% estimated exploitation activity in the next 30 days; percentile 23.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description NVIDIA NeMo contains a vulnerability in ASR WebApp, where Relative Path Traversal (CWE-23) may lead to deletion of any directory through the "../" structure when admin privileges are available. CVSS Score = 2.0 https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N Impact When the optional tool ASR Webapp (https://github.com/NVIDIA/NeMo/tree/main/tools/asrwebapp) is used prior to commit https://github.com/NVIDIA/NeMo/commit/f7e4ed7e4f7f2fa43765a38c2fafa1b6d1ebd7c0, some interfaces do not verify user input. Malicious attackers can construct malicious requests to delete any directory through the "../" structure. The vulnerability affects only cases where this particular web app is started by a user with superuser permissions. The web application is not a part of the regular pip release or the corresponding container, and impacts only users that clone the repository in its entirety and execute the web app (while also possessing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rpx7-33j2-xx9x
- Revision 2 · amended ·
Amended from osv record GHSA-rpx7-33j2-xx9x
- Revision 1 · created ·
Published from osv record GHSA-9hg3-hmmf-c3gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-22821 Advisory: Arbitrary file deletion in NeMo ASR webapp IDs: CVE-2022-22821, GHSA-9hg3-hmmf-c3gr Record: https://patchnext.com/advisories/cve-2022-22821 (revision 3, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nemo-toolkit 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nemo-toolkit: affected < 1.6.0; fixed in 1.6.0 ## Suggested inspection (read-only) - `python -m pip show nemo-toolkit`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nemo-toolkit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9hg3-hmmf-c3gr (OSV record GHSA-9hg3-hmmf-c3gr lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-rpx7-33j2-xx9x (OSV record GHSA-rpx7-33j2-xx9x lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rpx7-33j2-xx9x (GitHub-reviewed advisory GHSA-rpx7-33j2-xx9x lists affected ranges: PyPI nemo-toolkit >=0 <1.6.0) Commands are suggestions: review each one before running it.
Loading voting…