NVIDIA NeMo Framework Deserializes Untrusted Data
CVE-2025-33253GHSA-hvjw-vp7g-39h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nemo-toolkit 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nemo-toolkit
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hvjw-vp7g-39h5 lists affected ranges: PyPI nemo-toolkit >=0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hvjw-vp7g-39h5 lists affected ranges: PyPI nemo-toolkit >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-33253: 0.23% estimated exploitation activity in the next 30 days; percentile 13.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NVIDIA NeMo Framework contains a vulnerability where an attacker could cause remote code execution by convincing a user to load a maliciously crafted file. A successful exploit of this vulnerability might lead to code execution, denial of service, information disclosure, and data tampering.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hvjw-vp7g-39h5
- Revision 1 · created ·
Published from osv record GHSA-hvjw-vp7g-39h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-33253 Advisory: NVIDIA NeMo Framework Deserializes Untrusted Data IDs: CVE-2025-33253, GHSA-hvjw-vp7g-39h5 Record: https://patchnext.com/advisories/cve-2025-33253 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nemo-toolkit 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nemo-toolkit: affected < 2.6.1; fixed in 2.6.1 ## Suggested inspection (read-only) - `python -m pip show nemo-toolkit`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nemo-toolkit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hvjw-vp7g-39h5 (OSV record GHSA-hvjw-vp7g-39h5 lists affected ranges: PyPI nemo-toolkit >=0 <2.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hvjw-vp7g-39h5 (GitHub-reviewed advisory GHSA-hvjw-vp7g-39h5 lists affected ranges: PyPI nemo-toolkit >=0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…