Skip to content

← Public intelligence

PyPI package

mem0ai

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PyPIAmendedPublished

    Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope)

    CVE-2026-116575 · GHSA-5324-3w58-qpp2

    Affected
    • PyPI mem0ai < 2.0.18
    Fixed in
    2.0.18· Vendor fix available
    Issue
    _build_session_scope() in mem0/memory/main.py builds the conversation-history scope key used to fetch/store the last N raw messages by naively joining caller-supplied user_id/agent_id/run_id values with unescaped & and = delimiters: def _build_session_scope(filters): parts = [] for key in sorted(["user_id", "agent_id", "run_id"]): val = filters.get(key) if val: parts.append(f"{key}={val}") return "&".join(parts) _validate_and_trim_entity_id() (the only validation applied to these values) rejects only empty/whitespace-only strings — it never forbids & or =. This scope string is then used as an exact-match key against a SQLite column (storage.py: WHERE session_scope = ?) to fetch the last 10 raw messages for a given scope (main.py, Phase 0 of _add_to_vector_store, both sync and async). Impact Any caller who controls only their own run_id (or agent_id) — a very common integration shape, since apps frequently pass a client-/session-supplied identifier straight through as run_id…

    Recommended action: Upgrade to 2.0.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.2PyPIAmendedPublished

    mem0ai Databricks vector store vulnerable to SQL injection

    CVE-2026-115324 · GHSA-7587-9684-52r6

    Affected
    • PyPI mem0ai >= 0.1.117, < 1.0.8
    Fixed in
    1.0.8· Vendor fix available
    Issue
    mem0 0.1.117 before 1.0.8 contains an sql injection vulnerability in mem0/vectorstores/databricks.py that allows attackers to inject SQL by influencing stored memory content. Attackers can supply crafted memory text, metadata, or message names that reach unescaped insert() and update() string interpolation to execute injected SQL on the configured Databricks SQL warehouse.

    Recommended action: Upgrade to 1.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  3. Low, CVSS 2.1PyPIAmendedPublished

    mem0ai mem0 has an Improper Input Validation Issue

    CVE-2026-7597 · GHSA-xqxw-r767-67m7

    Affected
    • PyPI mem0ai < 2.0.0b2
    Fixed in
    2.0.0b2· Vendor fix available
    Issue
    A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vectorstores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.

    Recommended action: Upgrade to 2.0.0b2 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →