Skip to content

← Actionable
Low, CVSS 2.1amended

mem0ai mem0 has an Improper Input Validation Issue

CVE-2026-7597GHSA-xqxw-r767-67m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mem0ai 2.0.0b2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mem0ai

    Affected
    < 2.0.0b2
    Fixed in
    2.0.0b2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-7597: 0.32% estimated exploitation activity in the next 30 days; percentile 24.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vectorstores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xqxw-r767-67m7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xqxw-r767-67m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-7597

Advisory: mem0ai mem0 has an Improper Input Validation Issue
IDs: CVE-2026-7597, GHSA-xqxw-r767-67m7
Record: https://patchnext.com/advisories/cve-2026-7597 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mem0ai 2.0.0b2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mem0ai: affected < 2.0.0b2; fixed in 2.0.0b2

## Suggested inspection (read-only)
- `python -m pip show mem0ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mem0ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xqxw-r767-67m7 (OSV record GHSA-xqxw-r767-67m7 lists affected ranges: PyPI mem0ai >=0 <2.0.0b2 (fixed))
- Verified: https://github.com/advisories/GHSA-xqxw-r767-67m7 (GitHub-reviewed advisory GHSA-xqxw-r767-67m7 lists affected ranges: PyPI mem0ai >=0 <2.0.0b2)

Commands are suggestions: review each one before running it.

Loading voting…