Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope)
CVE-2026-116575GHSA-5324-3w58-qpp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mem0ai 2.0.18; mem0ai 3.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5324-3w58-qpp2 lists affected ranges: PyPI mem0ai >=0 =0 <3.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5324-3w58-qpp2 lists affected ranges: PyPI mem0ai >=0 =0 <3.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-116575: 0.11% estimated exploitation activity in the next 30 days; percentile 1.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary _build_session_scope() in mem0/memory/main.py builds the conversation-history scope key used to fetch/store the last N raw messages by naively joining caller-supplied user_id/agent_id/run_id values with unescaped & and = delimiters: def _build_session_scope(filters): parts = [] for key in sorted(["user_id", "agent_id", "run_id"]): val = filters.get(key) if val: parts.append(f"{key}={val}") return "&".join(parts) _validate_and_trim_entity_id() (the only validation applied to these values) rejects only empty/whitespace-only strings — it never forbids & or =. This scope string is then used as an exact-match key against a SQLite column (storage.py: WHERE session_scope = ?) to fetch the last 10 raw messages for a given scope (main.py, Phase 0 of _add_to_vector_store, both sync and async). Impact Any caller who controls only their own run_id (or agent_id) — a very common integration shape, since apps frequently pass a client-/session-supplied identifier straight through as run_id…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-5324-3w58-qpp2
- Revision 1 · created ·
Published from ghsa record GHSA-5324-3w58-qpp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116575 Advisory: Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope) IDs: CVE-2026-116575, GHSA-5324-3w58-qpp2 Record: https://patchnext.com/advisories/cve-2026-116575 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mem0ai 2.0.18; mem0ai 3.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mem0ai: affected < 2.0.18; fixed in 2.0.18 - npm mem0ai: affected < 3.1.6; fixed in 3.1.6 ## Suggested inspection (read-only) - `python -m pip show mem0ai`: prints the installed version. Run with the environment that serves production active. - `npm ls mem0ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mem0ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5324-3w58-qpp2 (OSV record GHSA-5324-3w58-qpp2 lists affected ranges: PyPI mem0ai >=0 =0 <3.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-5324-3w58-qpp2 (GitHub-reviewed advisory GHSA-5324-3w58-qpp2 lists affected ranges: PyPI mem0ai >=0 =0 <3.1.6) Commands are suggestions: review each one before running it.
Loading voting…