Skip to content

← Public intelligence

PyPI package

irrd

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PyPIAmendedPublished

    IRRd: web UI host header injection allows password reset poisoning via attacker-controlled email links

    CVE-2026-28681 · GHSA-22m3-c7vp-49fj

    Affected
    • PyPI irrd >= 4.4.0, < 4.4.5; >= 4.5.0, < 4.5.1
    Fixed in
    4.5.14.4.5· Vendor fix available
    Issue
    Impact An attacker can manipulate the HTTP Host header on a password reset or account creation request. The confirmation link in the resulting email can then point to an attacker-controlled domain. Opening the link in the email is sufficient to pass the token to the attacker, who can then use it on the real IRRD instance to take over the account. A compromised account can then be used to modify RPSL objects maintained by the account's mntners and perform other account actions. If the user had two-factor authentication configured, which is required for users with override access, an attacker is not able to log in, even after successfully resetting the password. This issue affects IRRD 4.5.0 and all 4.4.x versions prior to 4.4.5. IRRD 4.3 and earlier are not affected, as they did not include the web UI. Cause Email links in account creation, password reset, and mntner migration emails were generated from the HTTP request context, allowing an attacker to manipulate the HTTP Host header…

    Recommended action: Upgrade to 4.5.1 or 4.4.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.1PyPIAmendedPublished

    Improper Removal of Sensitive Information Before Storage or Transfer in irrd

    CVE-2022-24798 · GHSA-cqxx-66wh-8pjw

    Affected
    • PyPI irrd >= 4.2.0, < 4.2.3
    Fixed in
    4.2.3· Vendor fix available
    Issue
    IRRd did not always filter password hashes in query responses relating to mntner objects and database exports. This may have allowed adversaries to retrieve some of these hashes, perform a brute-force search for the clear-text passphrase, and use these to make unauthorised changes to affected IRR objects. This issue only affected instances that process password hashes, which means it is limited to IRRd instances that serve authoritative databases. IRRd instances operating solely as mirrors of other IRR databases are not affected. The issue occurred: For mntner objects where all password hash names (MD5-PW and CRYPT-PW) were in lower or mixed case in the auth attribute. For these objects, hashes remained in the output of all queries of any method and all database exports made with the exportdestination setting. Fortunately, objects in the common public IRR database virtually all use uppercase hash names which means very few of those objects were affected. For any GraphQL queries that…

    Recommended action: Upgrade to 4.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →