Skip to content

← Actionable
High, CVSS 8.1amended

IRRd: web UI host header injection allows password reset poisoning via attacker-controlled email links

CVE-2026-28681GHSA-22m3-c7vp-49fj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (irrd 4.5.1, 4.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI irrd

    Affected
    >= 4.4.0, < 4.4.5>= 4.5.0, < 4.5.1
    Fixed in
    4.5.1, 4.4.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-28681: 0.49% estimated exploitation activity in the next 30 days; percentile 41.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can manipulate the HTTP Host header on a password reset or account creation request. The confirmation link in the resulting email can then point to an attacker-controlled domain. Opening the link in the email is sufficient to pass the token to the attacker, who can then use it on the real IRRD instance to take over the account. A compromised account can then be used to modify RPSL objects maintained by the account's mntners and perform other account actions. If the user had two-factor authentication configured, which is required for users with override access, an attacker is not able to log in, even after successfully resetting the password. This issue affects IRRD 4.5.0 and all 4.4.x versions prior to 4.4.5. IRRD 4.3 and earlier are not affected, as they did not include the web UI. Cause Email links in account creation, password reset, and mntner migration emails were generated from the HTTP request context, allowing an attacker to manipulate the HTTP Host header…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-22m3-c7vp-49fj

  2. Revision 1 · created ·

    Published from osv record GHSA-22m3-c7vp-49fj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28681

Advisory: IRRd: web UI host header injection allows password reset poisoning via attacker-controlled email links
IDs: CVE-2026-28681, GHSA-22m3-c7vp-49fj
Record: https://patchnext.com/advisories/cve-2026-28681 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: irrd 4.5.1, 4.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI irrd: affected >= 4.4.0, < 4.4.5; >= 4.5.0, < 4.5.1; fixed in 4.5.1, 4.4.5

## Suggested inspection (read-only)
- `python -m pip show irrd`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on irrd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-22m3-c7vp-49fj (OSV record GHSA-22m3-c7vp-49fj lists affected ranges: PyPI irrd >=4.4.0 =4.5.0 <4.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-22m3-c7vp-49fj (GitHub-reviewed advisory GHSA-22m3-c7vp-49fj lists affected ranges: PyPI irrd >=4.4.0 =4.5.0 <4.5.1)

Commands are suggestions: review each one before running it.

Loading voting…