Skip to content

← Actionable
High, CVSS 7.1amended

Improper Removal of Sensitive Information Before Storage or Transfer in irrd

CVE-2022-24798GHSA-cqxx-66wh-8pjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (irrd 4.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI irrd

    Affected
    >= 4.2.0, < 4.2.3
    Fixed in
    4.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-24798: 1.42% estimated exploitation activity in the next 30 days; percentile 72.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

IRRd did not always filter password hashes in query responses relating to mntner objects and database exports. This may have allowed adversaries to retrieve some of these hashes, perform a brute-force search for the clear-text passphrase, and use these to make unauthorised changes to affected IRR objects. This issue only affected instances that process password hashes, which means it is limited to IRRd instances that serve authoritative databases. IRRd instances operating solely as mirrors of other IRR databases are not affected. The issue occurred: For mntner objects where all password hash names (MD5-PW and CRYPT-PW) were in lower or mixed case in the auth attribute. For these objects, hashes remained in the output of all queries of any method and all database exports made with the exportdestination setting. Fortunately, objects in the common public IRR database virtually all use uppercase hash names which means very few of those objects were affected. For any GraphQL queries that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cqxx-66wh-8pjw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cqxx-66wh-8pjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24798

Advisory: Improper Removal of Sensitive Information Before Storage or Transfer in irrd
IDs: CVE-2022-24798, GHSA-cqxx-66wh-8pjw
Record: https://patchnext.com/advisories/cve-2022-24798 (revision 3, source checked 26 Oct 2026, 13:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: irrd 4.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI irrd: affected >= 4.2.0, < 4.2.3; fixed in 4.2.3

## Suggested inspection (read-only)
- `python -m pip show irrd`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on irrd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cqxx-66wh-8pjw (OSV record GHSA-cqxx-66wh-8pjw lists affected ranges: PyPI irrd >=4.2.0 <4.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-cqxx-66wh-8pjw (GitHub-reviewed advisory GHSA-cqxx-66wh-8pjw lists affected ranges: PyPI irrd >=4.2.0 <4.2.3)

Commands are suggestions: review each one before running it.

Loading voting…