Skip to content

← Public intelligence

PyPI package

ipa

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9PyPIAmendedPublished

    FreeIPA logs passwords embedded in commands in calls using batch

    CVE-2019-10195 · GHSA-w4q7-f34x-vpgc

    Affected
    • PyPI ipa >= 4.6.0, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3
    Fixed in
    4.8.34.6.74.7.4· Vendor fix available
    Issue
    A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.

    Recommended action: Upgrade to 4.8.3, 4.7.4 or 4.6.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    Code injection in FreeIPA

    CVE-2019-14867 · GHSA-7hpj-hfcr-5qwm

    Affected
    • PyPI ipa >= 4.6.2, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3
    Fixed in
    4.8.34.6.74.7.4· Vendor fix available
    Issue
    A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function berscanf() was used in some components of the IPA server, which parsed kerberos key data. An unauthenticated attacker who could trigger parsing of the krb principal key could cause the IPA server to crash or in some conditions, cause arbitrary code to be executed on the server hosting the IPA server.

    Recommended action: Upgrade to 4.8.3, 4.7.4 or 4.6.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →