Skip to content

← Actionable
High, CVSS 8.7amended

Code injection in FreeIPA

CVE-2019-14867GHSA-7hpj-hfcr-5qwm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (freeipa 4.8.3, 4.7.4, 4.6.7; ipa 4.8.3, 4.7.4, 4.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI freeipa

    Affected
    >= 4.6.2, < 4.6.7>= 4.7.0, < 4.7.4>= 4.8.0, < 4.8.3
    Fixed in
    4.8.3, 4.6.7, 4.7.4
  • PyPI ipa

    Affected
    >= 4.6.2, < 4.6.7>= 4.7.0, < 4.7.4>= 4.8.0, < 4.8.3
    Fixed in
    4.8.3, 4.6.7, 4.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-14867: 7.41% estimated exploitation activity in the next 30 days; percentile 94.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function berscanf() was used in some components of the IPA server, which parsed kerberos key data. An unauthenticated attacker who could trigger parsing of the krb principal key could cause the IPA server to crash or in some conditions, cause arbitrary code to be executed on the server hosting the IPA server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7hpj-hfcr-5qwm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7hpj-hfcr-5qwm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-14867

Advisory: Code injection in FreeIPA
IDs: CVE-2019-14867, GHSA-7hpj-hfcr-5qwm
Record: https://patchnext.com/advisories/cve-2019-14867 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: freeipa 4.8.3, 4.7.4, 4.6.7; ipa 4.8.3, 4.7.4, 4.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI freeipa: affected >= 4.6.2, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3; fixed in 4.8.3, 4.6.7, 4.7.4
- PyPI ipa: affected >= 4.6.2, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3; fixed in 4.8.3, 4.6.7, 4.7.4

## Suggested inspection (read-only)
- `python -m pip show freeipa`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show ipa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on freeipa, ipa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7hpj-hfcr-5qwm (OSV record GHSA-7hpj-hfcr-5qwm lists affected ranges: PyPI ipa >=4.6.2 =4.7.0 =4.8.0 =4.6.2 =4.7.0 =4.8.0 <4.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-7hpj-hfcr-5qwm (GitHub-reviewed advisory GHSA-7hpj-hfcr-5qwm lists affected ranges: PyPI ipa >=4.6.2 =4.7.0 =4.8.0 =4.6.2 =4.7.0 =4.8.0 <4.8.3)

Commands are suggestions: review each one before running it.

Loading voting…