Skip to content

← Actionable
Medium, CVSS 6.9amended

FreeIPA logs passwords embedded in commands in calls using batch

CVE-2019-10195GHSA-w4q7-f34x-vpgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (freeipa 4.8.3, 4.7.4, 4.6.7; ipa 4.8.3, 4.7.4, 4.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI freeipa

    Affected
    >= 4.6.0, < 4.6.7>= 4.7.0, < 4.7.4>= 4.8.0, < 4.8.3
    Fixed in
    4.8.3, 4.6.7, 4.7.4
  • PyPI ipa

    Affected
    >= 4.6.0, < 4.6.7>= 4.7.0, < 4.7.4>= 4.8.0, < 4.8.3
    Fixed in
    4.8.3, 4.6.7, 4.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-10195: 1.81% estimated exploitation activity in the next 30 days; percentile 78.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w4q7-f34x-vpgc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w4q7-f34x-vpgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10195

Advisory: FreeIPA logs passwords embedded in commands in calls using batch
IDs: CVE-2019-10195, GHSA-w4q7-f34x-vpgc
Record: https://patchnext.com/advisories/cve-2019-10195 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: freeipa 4.8.3, 4.7.4, 4.6.7; ipa 4.8.3, 4.7.4, 4.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI freeipa: affected >= 4.6.0, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3; fixed in 4.8.3, 4.6.7, 4.7.4
- PyPI ipa: affected >= 4.6.0, < 4.6.7; >= 4.7.0, < 4.7.4; >= 4.8.0, < 4.8.3; fixed in 4.8.3, 4.6.7, 4.7.4

## Suggested inspection (read-only)
- `python -m pip show freeipa`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show ipa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on freeipa, ipa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w4q7-f34x-vpgc (OSV record GHSA-w4q7-f34x-vpgc lists affected ranges: PyPI freeipa >=4.6.0 =4.7.0 =4.8.0 =4.6.0 =4.7.0 =4.8.0 <4.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-w4q7-f34x-vpgc (GitHub-reviewed advisory GHSA-w4q7-f34x-vpgc lists affected ranges: PyPI freeipa >=4.6.0 =4.7.0 =4.8.0 =4.6.0 =4.7.0 =4.8.0 <4.8.3)

Commands are suggestions: review each one before running it.

Loading voting…