Skip to content

← Public intelligence

PyPI package

h2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIPublished

    h2: Duplicate Host header could facilitate request smuggling

    CVE-2026-71554 · GHSA-6hr6-w5qg-qmwg

    Affected
    • PyPI h2 <= 4.4.0
    Fixed in
    4.4.1· Vendor fix available
    Issue
    Impact h2 <=4.4.0 accepts request header blocks containing more than one Host header, and forwards every Host header to the consuming application. Where the consumer downgrades HTTP/2 to HTTP/1.1, the resulting request carries two Host header lines, which is a request smuggling primitive (CWE-444). Patches Patched and fixed in v4.4.1 Workarounds Users of the h2 library are advised to check and follow HTTP semantics best practices in their application code. h2 provides best effort sanity checks, but ultimately the calling code is responsible to ensure proper and safe usage of HTTP/2 as provided by h2, hyperframe, and hpack. References Similar to the previously disclosed and fixed duplicate content-length issue.

    Recommended action: Upgrade to 4.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.9PyPIAmendedPublished

    h2 allows HTTP Request Smuggling due to illegal characters in headers

    CVE-2025-57804 · GHSA-847f-9342-265h

    Affected
    • PyPI h2 < 4.3.0
    Fixed in
    4.3.0· Vendor fix available
    Issue
    HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls.

    Recommended action: Upgrade to 4.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →