h2 allows HTTP Request Smuggling due to illegal characters in headers
CVE-2025-57804GHSA-847f-9342-265h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (h2 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI h2
- Affected
- < 4.3.0
- Fixed in
- 4.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-847f-9342-265h lists affected ranges: PyPI h2 >=0 <4.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-847f-9342-265h lists affected ranges: PyPI h2 >=0 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2025-57804: 1.88% estimated exploitation activity in the next 30 days; percentile 79.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-847f-9342-265h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-847f-9342-265h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57804 Advisory: h2 allows HTTP Request Smuggling due to illegal characters in headers IDs: CVE-2025-57804, GHSA-847f-9342-265h Record: https://patchnext.com/advisories/cve-2025-57804 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: h2 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI h2: affected < 4.3.0; fixed in 4.3.0 ## Suggested inspection (read-only) - `python -m pip show h2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on h2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-847f-9342-265h (OSV record GHSA-847f-9342-265h lists affected ranges: PyPI h2 >=0 <4.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-847f-9342-265h (GitHub-reviewed advisory GHSA-847f-9342-265h lists affected ranges: PyPI h2 >=0 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…