Skip to content

← Actionable
Medium, CVSS 5.3

h2: Duplicate Host header could facilitate request smuggling

CVE-2026-71554GHSA-6hr6-w5qg-qmwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (h2 4.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI h2

    Affected
    <= 4.4.0
    Fixed in
    4.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-71554: 0.42% estimated exploitation activity in the next 30 days; percentile 36.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact h2 <=4.4.0 accepts request header blocks containing more than one Host header, and forwards every Host header to the consuming application. Where the consumer downgrades HTTP/2 to HTTP/1.1, the resulting request carries two Host header lines, which is a request smuggling primitive (CWE-444). Patches Patched and fixed in v4.4.1 Workarounds Users of the h2 library are advised to check and follow HTTP semantics best practices in their application code. h2 provides best effort sanity checks, but ultimately the calling code is responsible to ensure proper and safe usage of HTTP/2 as provided by h2, hyperframe, and hpack. References Similar to the previously disclosed and fixed duplicate content-length issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6hr6-w5qg-qmwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71554

Advisory: h2: Duplicate Host header could facilitate request smuggling
IDs: CVE-2026-71554, GHSA-6hr6-w5qg-qmwg
Record: https://patchnext.com/advisories/cve-2026-71554 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: h2 4.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI h2: affected <= 4.4.0; fixed in 4.4.1

## Suggested inspection (read-only)
- `python -m pip show h2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on h2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6hr6-w5qg-qmwg (GitHub-reviewed advisory GHSA-6hr6-w5qg-qmwg lists affected ranges: PyPI h2 >=0 <=4.4.0)

Commands are suggestions: review each one before running it.

Loading voting…