Skip to content

← Public intelligence

PyPI package

apache-airflow-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8PyPIAmendedPublished

    Apache Airflow: Execution API JWT leaked via KubernetesExecutor worker command-line args

    CVE-2026-49298 · GHSA-5j6p-jrrm-6x94

    Affected
    • PyPI apache-airflow-core < 3.2.2
    Fixed in
    3.2.2· Vendor fix available
    Issue
    A bug in Apache Airflow's KubernetesExecutor caused JWT tokens used by worker pods to authenticate against the Execution API to be passed to the worker container as command-line arguments visible in the pod spec. An authenticated UI/API user with Kubernetes read-only access to the cluster (e.g. pods/get in the Airflow namespace) could harvest the JWT from kubectl describe pod output and then call state-mutating Execution API endpoints — triggering Dag runs, clearing runs, reading or writing Variables / Connections / XComs — as if they were a running task. Affects deployments using the KubernetesExecutor. Users are advised to upgrade to apache-airflow 3.2.2 or later. This is the airflow-core half of the same vulnerability addressed by CVE-2026-27173, which shipped the apache-airflow-providers-cncf-kubernetes side of the fix. Deployments that already upgraded apache-airflow-providers-cncf-kubernetes to 10.17.0 or later per the CVE-2026-27173 advisory should additionally upgrade…

    Recommended action: Upgrade to 3.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Apache Airflow exposes SQL stack trace despite "api/expose_stack_traces" set to false

    CVE-2026-30912 · GHSA-w7cf-2pmc-5m4c

    Affected
    • PyPI apache-airflow-core < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    In case of SQL errors, exception/stack trace of errors was exposed in API even if "api/exposestacktraces" was set to false. That could lead to exposing additional information to potential attacker. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →
  3. High, CVSS 7.5PyPIAmendedPublished

    Apache Airflow allows users with asset materialize permissions to trigger DAGs outside of their permissions

    CVE-2026-32228 · GHSA-h97w-pm3w-mwmc

    Affected
    • PyPI apache-airflow-core >= 3.0.0, < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.2PyPIAmendedPublished

    Apache Airflow allows code execution through crafted XCom payloads

    CVE-2026-25917 · GHSA-6ffj-2wg2-w45j

    Affected
    • PyPI apache-airflow-core < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →
  5. Low, CVSS 3.7PyPIAmendedPublished

    Apache Airflow Exposes Secrets in Variables Saved as JSON Dictionaries

    CVE-2026-32690 · GHSA-w9r4-94fj-xp69

    Affected
    • PyPI apache-airflow-core >= 3.0.0, < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Secrets in Variables saved as JSON dictionaries were not properly redacted - in case the variables were retrieved by the user the secrets stored as nested fields were not masked. If developers do not store variables with sensitive values in JSON form, their projects are not affected. Otherwise upgrade to the fixed version, Apache Airflow 3.2.0.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →