Skip to content

← Actionable
High, CVSS 7.2amended

Apache Airflow allows code execution through crafted XCom payloads

CVE-2026-25917GHSA-6ffj-2wg2-w45j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-core 3.2.0; apache-airflow 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-25917: 0.82% estimated exploitation activity in the next 30 days; percentile 57.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6ffj-2wg2-w45j

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2026-13

  3. Revision 1 · created ·

    Published from osv record GHSA-6ffj-2wg2-w45j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25917

Advisory: Apache Airflow allows code execution through crafted XCom payloads
IDs: CVE-2026-25917, GHSA-6ffj-2wg2-w45j
Record: https://patchnext.com/advisories/cve-2026-25917 (revision 3, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-core 3.2.0; apache-airflow 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-core: affected < 3.2.0; fixed in 3.2.0
- PyPI apache-airflow: affected < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-core`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-core, apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6ffj-2wg2-w45j (OSV record GHSA-6ffj-2wg2-w45j lists affected ranges: PyPI apache-airflow-core >=0 <3.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2026-13 (OSV record PYSEC-2026-13 lists affected ranges: PyPI apache-airflow >=0 <3.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6ffj-2wg2-w45j (GitHub-reviewed advisory GHSA-6ffj-2wg2-w45j lists affected ranges: PyPI apache-airflow-core >=0 <3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…