Skip to content

← Actionable
High, CVSS 8.8amended

Apache Airflow: Execution API JWT leaked via KubernetesExecutor worker command-line args

CVE-2026-49298GHSA-5j6p-jrrm-6x94

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-core 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-49298: 0.49% estimated exploitation activity in the next 30 days; percentile 42.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A bug in Apache Airflow's KubernetesExecutor caused JWT tokens used by worker pods to authenticate against the Execution API to be passed to the worker container as command-line arguments visible in the pod spec. An authenticated UI/API user with Kubernetes read-only access to the cluster (e.g. pods/get in the Airflow namespace) could harvest the JWT from kubectl describe pod output and then call state-mutating Execution API endpoints — triggering Dag runs, clearing runs, reading or writing Variables / Connections / XComs — as if they were a running task. Affects deployments using the KubernetesExecutor. Users are advised to upgrade to apache-airflow 3.2.2 or later. This is the airflow-core half of the same vulnerability addressed by CVE-2026-27173, which shipped the apache-airflow-providers-cncf-kubernetes side of the fix. Deployments that already upgraded apache-airflow-providers-cncf-kubernetes to 10.17.0 or later per the CVE-2026-27173 advisory should additionally upgrade…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5j6p-jrrm-6x94

  2. Revision 1 · created ·

    Published from osv record GHSA-5j6p-jrrm-6x94

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49298

Advisory: Apache Airflow: Execution API JWT leaked via KubernetesExecutor worker command-line args
IDs: CVE-2026-49298, GHSA-5j6p-jrrm-6x94
Record: https://patchnext.com/advisories/cve-2026-49298 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-core 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-core: affected < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5j6p-jrrm-6x94 (OSV record GHSA-5j6p-jrrm-6x94 lists affected ranges: PyPI apache-airflow-core >=0 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5j6p-jrrm-6x94 (GitHub-reviewed advisory GHSA-5j6p-jrrm-6x94 lists affected ranges: PyPI apache-airflow-core >=0 <3.2.2)

Commands are suggestions: review each one before running it.

Loading voting…