Skip to content

← Public intelligence

PyPI package

ansible-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8PyPIAmendedPublished

    ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution

    CVE-2026-11332 · GHSA-w8p5-mx5w-cpqj

    Affected
    • PyPI ansible-core < 2.16.19rc1; >= 2.17.0b1, < 2.18.18rc1; >= 2.19.0b1, < 2.19.11rc1; >= 2.20.0b1, < 2.20.7rc1; >= 2.21.0b1, < 2.21.1rc1
    Fixed in
    2.19.11rc12.18.18rc12.20.7rc12.16.19rc12.21.1rc1· Vendor fix available
    Issue
    A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.

    Recommended action: Upgrade to 2.21.1rc1 (pre-release), 2.20.7rc1 (pre-release), 2.19.11rc1 (pre-release) or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Low, CVSS 1.2PyPIAmendedPublished

    Ansible-Core vulnerable to content protections bypass

    CVE-2024-11079 · GHSA-99w6-3xph-cx78

    Affected
    • PyPI ansible-core >= 2.18.0b1, < 2.18.1rc1; >= 2.17.0b1, < 2.17.7rc1; < 2.16.14rc1
    Fixed in
    2.16.14rc12.18.1rc12.17.7rc1· Vendor fix available
    Issue
    A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

    Recommended action: Upgrade to 2.18.1rc1 (pre-release), 2.17.7rc1 (pre-release) or 2.16.14rc1 (pre-release) by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.3PyPIAmendedPublished

    ansible-core Incorrect Authorization vulnerability

    CVE-2024-9902 · GHSA-32p4-gm2c-wmch

    Affected
    • PyPI ansible-core < 2.14.18rc1; >= 2.15.0b1, < 2.15.13rc1; >= 2.16.0b1, < 2.16.13rc1; >= 2.17.0b1, < 2.17.6rc1; >= 2.18.0b1, < 2.18.0rc2
    Fixed in
    2.15.13rc12.16.13rc12.17.6rc12.18.0rc22.14.18rc1· Vendor fix available
    Issue
    A flaw was found in Ansible. The ansible-core user module can allow an unprivileged user to silently create or replace the contents of any file on any system path and take ownership of it when a privileged user executes the user module against the unprivileged user's home directory. If the unprivileged user has traversal permissions on the directory containing the exploited target file, they retain full control over the contents of the file as its owner.

    Recommended action: Upgrade to 2.18.0rc2 (pre-release), 2.17.6rc1 (pre-release), 2.16.13rc1 (pre-release) or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.1PyPIAmendedPublished

    Ansible vulnerable to Insertion of Sensitive Information into Log File

    CVE-2024-8775 · GHSA-jpxc-vmjf-9fcj

    Affected
    • PyPI ansible-core >= 2.17.0b1, < 2.17.6; < 2.16.13
    Fixed in
    2.17.62.16.13· Vendor fix available
    Issue
    A flaw was found in Ansible, where sensitive information stored in Ansible Vault files can be exposed in plaintext during the execution of a playbook. This occurs when using tasks such as includevars to load vaulted variables without setting the nolog: true parameter, resulting in sensitive data being printed in the playbook output or logs. This can lead to the unintentional disclosure of secrets like passwords or API keys, compromising security and potentially allowing unauthorized access or actions.

    Recommended action: Upgrade to 2.17.6 or 2.16.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 5.0PyPIAmendedPublished

    Ansible-core information disclosure flaw

    CVE-2024-0690 · GHSA-h24r-m9qc-pvpg

    Affected
    • PyPI ansible-core < 2.14.14; >= 2.16.0, < 2.16.3; >= 2.15.0, < 2.15.9
    Fixed in
    2.15.92.16.32.14.14· Vendor fix available
    Issue
    An information disclosure flaw was found in ansible-core due to a failure to respect the ANSIBLENOLOG configuration in some scenarios. It was discovered that information is still included in the output in certain tasks, such as loop items. Depending on the task, this issue may include sensitive information, such as decrypted secret values.

    Recommended action: Upgrade to 2.16.3, 2.15.9 or 2.14.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.6PyPIAmendedPublished

    Ansible template injection vulnerability

    CVE-2023-5764 · GHSA-7j69-qfc3-2fq9

    Affected
    • PyPI ansible-core >= 2.16.0, < 2.16.1; >= 2.15.0, < 2.15.8; < 2.14.12
    Fixed in
    2.16.12.14.122.15.8· Vendor fix available
    Issue
    A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data. This issue could allow an attacker to use a specially crafted file to introduce templating injection when supplying templating data.

    Recommended action: Upgrade to 2.16.1, 2.15.8 or 2.14.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →