Skip to content

← Actionable
Medium, CVSS 6.6amended

Ansible template injection vulnerability

CVE-2023-5764GHSA-7j69-qfc3-2fq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible-core 2.16.1, 2.15.8, 2.14.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible-core

    Affected
    >= 2.16.0, < 2.16.1>= 2.15.0, < 2.15.8< 2.14.12
    Fixed in
    2.16.1, 2.14.12, 2.15.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-5764: 0.57% estimated exploitation activity in the next 30 days; percentile 47.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data. This issue could allow an attacker to use a specially crafted file to introduce templating injection when supplying templating data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7j69-qfc3-2fq9

  2. Revision 1 · created ·

    Published from osv record GHSA-7j69-qfc3-2fq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-5764

Advisory: Ansible template injection vulnerability
IDs: CVE-2023-5764, GHSA-7j69-qfc3-2fq9
Record: https://patchnext.com/advisories/cve-2023-5764 (revision 2, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible-core 2.16.1, 2.15.8, 2.14.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible-core: affected >= 2.16.0, < 2.16.1; >= 2.15.0, < 2.15.8; < 2.14.12; fixed in 2.16.1, 2.14.12, 2.15.8

## Suggested inspection (read-only)
- `python -m pip show ansible-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7j69-qfc3-2fq9 (OSV record GHSA-7j69-qfc3-2fq9 lists affected ranges: PyPI ansible-core >=2.16.0 =2.15.0 =0 <2.14.12 (fixed))
- Verified: https://github.com/advisories/GHSA-7j69-qfc3-2fq9 (GitHub-reviewed advisory GHSA-7j69-qfc3-2fq9 lists affected ranges: PyPI ansible-core >=2.16.0 =2.15.0 =0 <2.14.12)

Commands are suggestions: review each one before running it.

Loading voting…