Skip to content

← Actionable
High, CVSS 7.8amended

ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution

CVE-2026-11332GHSA-w8p5-mx5w-cpqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible-core 2.21.1rc1, 2.20.7rc1, 2.19.11rc1, 2.18.18rc1, 2.16.19rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible-core

    Affected
    < 2.16.19rc1>= 2.17.0b1, < 2.18.18rc1>= 2.19.0b1, < 2.19.11rc1>= 2.20.0b1, < 2.20.7rc1>= 2.21.0b1, < 2.21.1rc1
    Fixed in
    2.19.11rc1, 2.18.18rc1, 2.20.7rc1, 2.16.19rc1, 2.21.1rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-11332: 0.22% estimated exploitation activity in the next 30 days; percentile 12.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w8p5-mx5w-cpqj

  2. Revision 1 · created ·

    Published from osv record GHSA-w8p5-mx5w-cpqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-11332

Advisory: ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution
IDs: CVE-2026-11332, GHSA-w8p5-mx5w-cpqj
Record: https://patchnext.com/advisories/cve-2026-11332 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible-core 2.21.1rc1, 2.20.7rc1, 2.19.11rc1, 2.18.18rc1, 2.16.19rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible-core: affected < 2.16.19rc1; >= 2.17.0b1, < 2.18.18rc1; >= 2.19.0b1, < 2.19.11rc1; >= 2.20.0b1, < 2.20.7rc1; >= 2.21.0b1, < 2.21.1rc1; fixed in 2.19.11rc1, 2.18.18rc1, 2.20.7rc1, 2.16.19rc1, 2.21.1rc1

## Suggested inspection (read-only)
- `python -m pip show ansible-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w8p5-mx5w-cpqj (OSV record GHSA-w8p5-mx5w-cpqj lists affected ranges: PyPI ansible-core >=0 =2.17.0b1 =2.19.0b1 =2.20.0b1 =2.21.0b1 <2.21.1rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-w8p5-mx5w-cpqj (GitHub-reviewed advisory GHSA-w8p5-mx5w-cpqj lists affected ranges: PyPI ansible-core >=0 =2.17.0b1 =2.19.0b1 =2.20.0b1 =2.21.0b1 <2.21.1rc1)

Commands are suggestions: review each one before running it.

Loading voting…