Skip to content

← Public intelligence

RubyGems package

spree

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.2RubyGemsPublished

    Spree: CSV Formula Injection in Customer Export

    GHSA-xf4v-w5x5-pv79

    Affected
    • RubyGems spree >= 5.2.0, < 5.2.8; >= 5.3.0, < 5.3.6; >= 5.4.0, < 5.4.3
    Fixed in
    5.4.35.2.85.3.6· Vendor fix available
    Issue
    CSV formula injection (also known as formula injection or CSV injection) affects customer export. User-controlled values customer names, email addresses, and shipping addresses. When an administrator opens a crafted Export in Microsoft Excel or LibreOffice Calc, formulas embedded in user data execute in the context of the administrator's desktop, potentially exfiltrating data or executing OS commands via DDE (Dynamic Data Exchange). --- Details Affected presenters and fields | Presenter | Path | User-controlled fields | |---|---|---| | CustomerPresenter | spree/core/app/presenters/spree/csv/customerpresenter.rb:36 | firstname, lastname, address1, address2, city, phone | Vulnerable code — customerpresenter.rb (representative example) --- PoC Precondition: A Spree store with public customer registration enabled (default configuration). No special permissions required for the attacker. Step 1 — Register as a customer with an injected first name Step 2 — Admin triggers a customer…

    Recommended action: Upgrade to 5.4.3, 5.3.6 or 5.2.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 10.0RubyGemsPublished

    Spree has Remote Command Execution vulnerability in search functionality

    CVE-2011-10019 · GHSA-97vm-c39p-jr86

    Affected
    • RubyGems spree < 0.60.2
    Fixed in
    0.60.2· Vendor fix available
    Issue
    Spreecommerce versions prior to 0.60.2 contains a remote command execution vulnerability in its search functionality. The application fails to properly sanitize input passed via the search[send][] parameter, which is dynamically invoked using Ruby’s send method. This allows attackers to execute arbitrary shell commands on the server without authentication.

    Recommended action: Upgrade to 0.60.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedRubyGemsPublished

    Spree does not properly restrict the use of a hash to provide values for a model's attributes

    CVE-2008-7310 · GHSA-7h48-m3rw-vr27

    Affected
    • RubyGems spree < 0.4.0
    Fixed in
    0.4.0· Vendor fix available
    Issue
    Spree 0.2.0 does not properly restrict the use of a hash to provide values for a model's attributes, which allows remote attackers to set the Order state value and bypass the intended payment step via a modified URL, related to a "mass assignment" vulnerability.

    Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedRubyGemsPublished

    Spree uses a hardcoded hash value

    CVE-2008-7311 · GHSA-g466-57gh-cqfw

    Affected
    • RubyGems spree < 0.4.0
    Fixed in
    0.4.0· Vendor fix available
    Issue
    The session cookie store implementation in Spree 0.2.0 uses a hardcoded config.actioncontrollersession hash value (aka secret key), which makes it easier for remote attackers to bypass cryptographic protection mechanisms by leveraging an application that contains this value within the config/environment.rb file.

    Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedRubyGemsPublished

    Spree allows remote attackers to obtain sensitive information

    CVE-2010-3978 · GHSA-hwrx-wc75-mgh7

    Affected
    • RubyGems spree >= 0.11.0, < 0.11.2; >= 0.30.0.beta1, <= 0.30.0.beta1
    Fixed in
    0.11.20.30.0· Vendor fix available
    Issue
    Spree 0.11.x before 0.11.2 and 0.30.x before 0.30.0 exchanges data using JavaScript Object Notation (JSON) without a mechanism for validating requests, which allows remote attackers to obtain sensitive information via vectors involving (1) admin/products.json, (2) admin/users.json, or (3) admin/overview/getreportdata, related to a "JSON hijacking" issue.

    Recommended action: Upgrade to 0.30.0 or 0.11.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.4RubyGemsPublished

    Ensure that doorkeeper_token is valid when authenticating requests in API v2 calls

    CVE-2020-15269 · GHSA-f8cm-364f-q9qh

    Affected
    • RubyGems spree < 3.7.11; >= 4.0.0, < 4.0.4; >= 4.1.0, < 4.1.11
    Fixed in
    4.1.114.0.43.7.11· Vendor fix available
    Issue
    Impact The perpetrator who previously obtained an old expired user token could use it to access Storefront API v2 endpoints. Patches Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Workarounds In your project directory create a decorator file app/controllers/spree/api/v2/basecontrollerdecotatror.rb with contents: For more information If you have any questions or comments about this advisory: Email us at security@spreecommerce.org

    Recommended action: Upgrade to 4.1.11, 4.0.4 or 3.7.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. UnratedRubyGemsPublished

    Spree Improper Input Validation vulnerability

    CVE-2013-1656 · GHSA-jxx8-v83v-rhw3

    Affected
    • RubyGems spree >= 1.0.0, < 2.0.0.rc1
    Fixed in
    2.0.0.rc1· Vendor fix available
    Issue
    Spree Commerce 1.0.x before 2.0.0.rc1 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) paymentmethod parameter to core/app/controllers/spree/admin/paymentmethodscontroller.rb; and the (2) promotionaction parameter to promotionactionscontroller.rb, (3) promotionrule parameter to promotionrulescontroller.rb, and (4) calculatortype parameter to promotionscontroller.rb in promo/app/controllers/spree/admin/, related to unsafe use of the constantize function.

    Recommended action: Upgrade to 2.0.0.rc1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →