Spree has Remote Command Execution vulnerability in search functionality
CVE-2011-10019GHSA-97vm-c39p-jr86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree 0.60.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems spree
- Affected
- < 0.60.2
- Fixed in
- 0.60.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-97vm-c39p-jr86 lists affected ranges: RubyGems spree >=0 <0.60.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2011-10019: 6.25% estimated exploitation activity in the next 30 days; percentile 93.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spreecommerce versions prior to 0.60.2 contains a remote command execution vulnerability in its search functionality. The application fails to properly sanitize input passed via the search[send][] parameter, which is dynamically invoked using Ruby’s send method. This allows attackers to execute arbitrary shell commands on the server without authentication.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-97vm-c39p-jr86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2011-10019 Advisory: Spree has Remote Command Execution vulnerability in search functionality IDs: CVE-2011-10019, GHSA-97vm-c39p-jr86 Record: https://patchnext.com/advisories/cve-2011-10019 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spree 0.60.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems spree: affected < 0.60.2; fixed in 0.60.2 ## Suggested inspection (read-only) - RubyGems spree: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spree. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-97vm-c39p-jr86 (GitHub-reviewed advisory GHSA-97vm-c39p-jr86 lists affected ranges: RubyGems spree >=0 <0.60.2) Commands are suggestions: review each one before running it.
Loading voting…