Skip to content

← Actionable
Medium, CVSS 5.2

Spree: CSV Formula Injection in Customer Export

GHSA-xf4v-w5x5-pv79

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree 5.4.3, 5.3.6, 5.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems spree

    Affected
    >= 5.2.0, < 5.2.8>= 5.3.0, < 5.3.6>= 5.4.0, < 5.4.3
    Fixed in
    5.4.3, 5.2.8, 5.3.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary CSV formula injection (also known as formula injection or CSV injection) affects customer export. User-controlled values customer names, email addresses, and shipping addresses. When an administrator opens a crafted Export in Microsoft Excel or LibreOffice Calc, formulas embedded in user data execute in the context of the administrator's desktop, potentially exfiltrating data or executing OS commands via DDE (Dynamic Data Exchange). --- Details Affected presenters and fields | Presenter | Path | User-controlled fields | |---|---|---| | CustomerPresenter | spree/core/app/presenters/spree/csv/customerpresenter.rb:36 | firstname, lastname, address1, address2, city, phone | Vulnerable code — customerpresenter.rb (representative example) --- PoC Precondition: A Spree store with public customer registration enabled (default configuration). No special permissions required for the attacker. Step 1 — Register as a customer with an injected first name Step 2 — Admin triggers a customer…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xf4v-w5x5-pv79

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xf4v-w5x5-pv79

Advisory: Spree: CSV Formula Injection in Customer Export
IDs: GHSA-xf4v-w5x5-pv79
Record: https://patchnext.com/advisories/ghsa-xf4v-w5x5-pv79 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spree 5.4.3, 5.3.6, 5.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems spree: affected >= 5.2.0, < 5.2.8; >= 5.3.0, < 5.3.6; >= 5.4.0, < 5.4.3; fixed in 5.4.3, 5.2.8, 5.3.6

## Suggested inspection (read-only)
- RubyGems spree: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spree.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xf4v-w5x5-pv79 (GitHub-reviewed advisory GHSA-xf4v-w5x5-pv79 lists affected ranges: RubyGems spree >=5.2.0 =5.3.0 =5.4.0 <5.4.3)

Commands are suggestions: review each one before running it.

Loading voting…