Skip to content

← Public intelligence

RubyGems package

bundler

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    Bundler allows attacker to inject arbitrary code via secondary Gem source

    CVE-2016-7954 · GHSA-jvgm-pfqv-887x

    Affected
    • RubyGems bundler >= 1.0.0, < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    Bundler may install gems from a different source than expected

    CVE-2013-0334 · GHSA-49jx-9cmc-xjxm

    Affected
    • RubyGems bundler < 1.7.0
    Fixed in
    1.7.0· Vendor fix available
    Issue
    Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.

    Recommended action: Upgrade to 1.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.7RubyGemsPublished

    Local Code Execution through Argument Injection via dash leading git url parameter in Gemfile.

    CVE-2021-43809 · GHSA-fj7f-vq84-fh43

    Affected
    • RubyGems bundler < 2.2.33
    Fixed in
    2.2.33· Vendor fix available
    Issue
    In bundler versions before 2.2.33, when working with untrusted and apparently harmless Gemfile's, it is not expected that they lead to execution of external code, unless that's explicit in the ruby code inside the Gemfile itself. However, if the Gemfile includes gem entries that use the git option with invalid, but seemingly harmless, values with a leading dash, this can be false. To handle dependencies that come from a Git repository instead of a registry, Bundler uses various commands, such as git clone. These commands are being constructed using user input (e.g. the repository URL). When building the commands, Bundler versions before 2.2.33 correctly avoid Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (-) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that…

    Recommended action: Upgrade to 2.2.33 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8RubyGemsPublished

    Dependency Confusion in Bundler

    CVE-2020-36327 · GHSA-fp4w-jxhp-m23p

    Affected
    • RubyGems bundler >= 1.16.0, < 2.2.10; >= 2.2.11, < 2.2.18
    Fixed in
    2.2.182.2.10· Vendor fix available
    Issue
    Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.

    Recommended action: Upgrade to 2.2.18 or 2.2.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.0RubyGemsPublished

    Insecure path handling in Bundler

    CVE-2019-3881 · GHSA-g98m-96g9-wfjq

    Affected
    • RubyGems bundler >= 1.14.0, < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →