Bundler may install gems from a different source than expected
CVE-2013-0334GHSA-49jx-9cmc-xjxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bundler 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems bundler
- Affected
- < 1.7.0
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49jx-9cmc-xjxm lists affected ranges: RubyGems bundler >=0 <1.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-0334: 4.30% estimated exploitation activity in the next 30 days; percentile 91.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bundler before 1.7, when multiple top-level source lines are used, allows remote attackers to install arbitrary gems by creating a gem with the same name as another gem in a different source.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-49jx-9cmc-xjxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-0334 Advisory: Bundler may install gems from a different source than expected IDs: CVE-2013-0334, GHSA-49jx-9cmc-xjxm Record: https://patchnext.com/advisories/cve-2013-0334 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bundler 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems bundler: affected < 1.7.0; fixed in 1.7.0 ## Suggested inspection (read-only) - RubyGems bundler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bundler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-49jx-9cmc-xjxm (GitHub-reviewed advisory GHSA-49jx-9cmc-xjxm lists affected ranges: RubyGems bundler >=0 <1.7.0) Commands are suggestions: review each one before running it.
Loading voting…