Skip to content

← Actionable
High, CVSS 8.8

Dependency Confusion in Bundler

CVE-2020-36327GHSA-fp4w-jxhp-m23p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bundler 2.2.18, 2.2.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems bundler

    Affected
    >= 1.16.0, < 2.2.10>= 2.2.11, < 2.2.18
    Fixed in
    2.2.18, 2.2.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-36327: 6.31% estimated exploitation activity in the next 30 days; percentile 93.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fp4w-jxhp-m23p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36327

Advisory: Dependency Confusion in Bundler
IDs: CVE-2020-36327, GHSA-fp4w-jxhp-m23p
Record: https://patchnext.com/advisories/cve-2020-36327 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bundler 2.2.18, 2.2.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems bundler: affected >= 1.16.0, < 2.2.10; >= 2.2.11, < 2.2.18; fixed in 2.2.18, 2.2.10

## Suggested inspection (read-only)
- RubyGems bundler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bundler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fp4w-jxhp-m23p (GitHub-reviewed advisory GHSA-fp4w-jxhp-m23p lists affected ranges: RubyGems bundler >=1.16.0 =2.2.11 <2.2.18)

Commands are suggestions: review each one before running it.

Loading voting…