Skip to content

← Public intelligence

Packagist package

tecnickcom/tcpdf

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    TCPDF has incorrect comparison

    CVE-2024-56522 · GHSA-w95c-7994-ghpr

    Affected
    • Packagist tecnickcom/tcpdf < 6.8.0
    Fixed in
    6.8.0· Vendor fix available
    Issue
    An issue was discovered in TCPDF before 6.8.0. unserializeTCPDFtag uses != (aka loose comparison) and does not use a constant-time function to compare TCPDF tag hashes.

    Recommended action: Upgrade to 6.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.8PackagistPublished

    TCPDF missing character escape on error messages

    CVE-2024-56527 · GHSA-qx95-cwh6-9mvq

    Affected
    • Packagist tecnickcom/tcpdf < 6.8.0
    Fixed in
    6.8.0· Vendor fix available
    Issue
    An issue was discovered in TCPDF before 6.8.0. The Error function lacks an htmlspecialchars call for the error message.

    Recommended action: Upgrade to 6.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.2PackagistPublished

    TCPDF missing certificate validation

    CVE-2024-56521 · GHSA-9mgx-552f-59p6

    Affected
    • Packagist tecnickcom/tcpdf < 6.8.0
    Fixed in
    6.8.0· Vendor fix available
    Issue
    An issue was discovered in TCPDF before 6.8.0. If libcurl is used, CURLOPTSSLVERIFYHOST and CURLOPTSSLVERIFYPEER are set unsafely.

    Recommended action: Upgrade to 6.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.3PackagistPublished

    TCPDF lacks SVG sanitization

    CVE-2024-56519 · GHSA-4p8j-vhjm-6pvw

    Affected
    • Packagist tecnickcom/tcpdf < 6.8.0
    Fixed in
    6.8.0· Vendor fix available
    Issue
    An issue was discovered in TCPDF before 6.8.0. setSVGStyles does not sanitize the SVG font-family attribute.

    Recommended action: Upgrade to 6.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.5PackagistPublished

    TCPDF Local File Inclusion vulnerability

    CVE-2024-51058 · GHSA-rmv2-8jjc-23xw

    Affected
    • Packagist tecnickcom/tcpdf <= 6.7.5
    Fixed in
    6.7.6· Vendor fix available
    Issue
    Local File Inclusion (LFI) vulnerability has been discovered in TCPDF 6.7.5. This vulnerability enables a user to read arbitrary files from the server's file system through <img src tag, potentially exposing sensitive information.

    Recommended action: Upgrade to 6.7.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.1PackagistPublished

    TCPDF vulnerable to Regular Expression Denial of Service

    CVE-2024-22640 · GHSA-mx3p-fhpw-x6rv

    Affected
    • Packagist tecnickcom/tcpdf <= 6.7.4
    Fixed in
    6.7.5· Vendor fix available
    Issue
    TCPDF version <= 6.7.4 is vulnerable to ReDoS (Regular Expression Denial of Service) if parsing an untrusted HTML page with a crafted color.

    Recommended action: Upgrade to 6.7.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 5.3PackagistPublished

    TCPDF Cross-site Scripting vulnerability

    CVE-2024-32489 · GHSA-g9wg-98c2-qv3v

    Affected
    • Packagist tecnickcom/tcpdf < 6.7.4
    Fixed in
    6.7.4· Vendor fix available
    Issue
    TCPDF before 6.7.4 mishandles calls that use HTML syntax.

    Recommended action: Upgrade to 6.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Critical, CVSS 9.8PackagistPublished

    TCPDF vulnerable to attackers triggering deserialization of arbitrary data

    CVE-2018-17057 · GHSA-5hw4-m7f3-hhx8

    Affected
    • Packagist tecnickcom/tcpdf < 6.2.22
    Fixed in
    6.2.22· Vendor fix available
    Issue
    An issue was discovered in TCPDF before 6.2.22. Attackers can trigger deserialization of arbitrary data via the phar:// wrapper.

    Recommended action: Upgrade to 6.2.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →