TCPDF vulnerable to attackers triggering deserialization of arbitrary data
CVE-2018-17057GHSA-5hw4-m7f3-hhx8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fooman/tcpdf 6.2.22; tecnickcom/tcpdf 6.2.22; la-haute-societe/tcpdf 6.2.22; spoonity/tcpdf 6.2.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist fooman/tcpdf
- Affected
- < 6.2.22
- Fixed in
- 6.2.22
Packagist tecnickcom/tcpdf
- Affected
- < 6.2.22
- Fixed in
- 6.2.22
Packagist la-haute-societe/tcpdf
- Affected
- < 6.2.22
- Fixed in
- 6.2.22
Packagist spoonity/tcpdf
- Affected
- < 6.2.22
- Fixed in
- 6.2.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hw4-m7f3-hhx8 lists affected ranges: Packagist tecnickcom/tcpdf >=0 =0 =0 =0 <6.2.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-17057: 26.17% estimated exploitation activity in the next 30 days; percentile 98.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in TCPDF before 6.2.22. Attackers can trigger deserialization of arbitrary data via the phar:// wrapper.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hw4-m7f3-hhx8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-17057 Advisory: TCPDF vulnerable to attackers triggering deserialization of arbitrary data IDs: CVE-2018-17057, GHSA-5hw4-m7f3-hhx8 Record: https://patchnext.com/advisories/cve-2018-17057 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fooman/tcpdf 6.2.22; tecnickcom/tcpdf 6.2.22; la-haute-societe/tcpdf 6.2.22; spoonity/tcpdf 6.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist fooman/tcpdf: affected < 6.2.22; fixed in 6.2.22 - Packagist tecnickcom/tcpdf: affected < 6.2.22; fixed in 6.2.22 - Packagist la-haute-societe/tcpdf: affected < 6.2.22; fixed in 6.2.22 - Packagist spoonity/tcpdf: affected < 6.2.22; fixed in 6.2.22 ## Suggested inspection (read-only) - Packagist fooman/tcpdf: check the installed version with your package manager. - Packagist tecnickcom/tcpdf: check the installed version with your package manager. - Packagist la-haute-societe/tcpdf: check the installed version with your package manager. - Packagist spoonity/tcpdf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fooman/tcpdf, tecnickcom/tcpdf, la-haute-societe/tcpdf, spoonity/tcpdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hw4-m7f3-hhx8 (GitHub-reviewed advisory GHSA-5hw4-m7f3-hhx8 lists affected ranges: Packagist tecnickcom/tcpdf >=0 =0 =0 =0 <6.2.22) Commands are suggestions: review each one before running it.
Loading voting…