TCPDF Local File Inclusion vulnerability
CVE-2024-51058GHSA-rmv2-8jjc-23xw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tecnickcom/tcpdf 6.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist tecnickcom/tcpdf
- Affected
- <= 6.7.5
- Fixed in
- 6.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmv2-8jjc-23xw lists affected ranges: Packagist tecnickcom/tcpdf >=0 <=6.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-51058: 0.81% estimated exploitation activity in the next 30 days; percentile 57.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Local File Inclusion (LFI) vulnerability has been discovered in TCPDF 6.7.5. This vulnerability enables a user to read arbitrary files from the server's file system through <img src tag, potentially exposing sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rmv2-8jjc-23xw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-51058 Advisory: TCPDF Local File Inclusion vulnerability IDs: CVE-2024-51058, GHSA-rmv2-8jjc-23xw Record: https://patchnext.com/advisories/cve-2024-51058 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tecnickcom/tcpdf 6.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist tecnickcom/tcpdf: affected <= 6.7.5; fixed in 6.7.6 ## Suggested inspection (read-only) - Packagist tecnickcom/tcpdf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tecnickcom/tcpdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rmv2-8jjc-23xw (GitHub-reviewed advisory GHSA-rmv2-8jjc-23xw lists affected ranges: Packagist tecnickcom/tcpdf >=0 <=6.7.5) Commands are suggestions: review each one before running it.
Loading voting…