Skip to content

← Public intelligence

Packagist package

prestashop/ps_facetedsearch

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0PackagistPublished

    prestashop/ps_facetedsearch: PHP Object Injection in faceted search cache allows unauthenticated RCE

    CVE-2026-54159 · GHSA-m5f5-28qr-9g9r

    Affected
    • Packagist prestashop/ps_facetedsearch >= 3.0.0, < 4.0.4
    Fixed in
    4.0.4· Vendor fix available
    Issue
    Impact A PHP Object Injection vulnerability affects the PrestaShop module psfacetedsearch. The module rebuilds the selected search filters from the request URL. The value of a slider filter (price or weight) is taken from the URL without sufficient validation, then stored in an internal filter-block cache where it is serialized and later read back with a raw native unserialize(). By crafting that value, an attacker can smuggle a malicious serialized PHP object into the cache. When it is deserialized, a gadget chain writes an arbitrary PHP file inside the module directory, which is then used as a webshell to run commands on the server. Who is impacted Any shop using a vulnerable version of psfacetedsearch that displays a filter template containing a slider filter (price or weight). Exploitation is remote and unauthenticated, a single crafted front-office request is enough, and leads to remote code execution and full compromise of the shop and its server. Affected versions: 3.0.0…

    Recommended action: Upgrade to 4.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedPackagistPublished

    PrestaShop module ps_facetedsearch might be vulnerable from CVE-2017-9841

    GHSA-f884-gm86-cg3q

    Affected
    • Packagist prestashop/ps_facetedsearch < 3.4.1
    Fixed in
    3.4.1· Vendor fix available
    Issue
    Impact We have identified that some psfacetedsearch module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE. This vulnerability impacts - phpunit before 4.8.28 and 5.x before 5.6.3 as reported in CVE-2017-9841 - phpunit = 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers) Patches In the security patch, we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading. Workarounds Users can also simply remove the unwanted vendor/phpunit folder. References https://nvd.nist.gov/vuln/detail/CVE-2017-9841 For more information If you have any questions or comments about this advisory, email us at security@prestashop.com

    Recommended action: Upgrade to 3.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →