PrestaShop module ps_facetedsearch might be vulnerable from CVE-2017-9841
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/ps_facetedsearch 3.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/ps_facetedsearch
- Affected
- < 3.4.1
- Fixed in
- 3.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f884-gm86-cg3q lists affected ranges: Packagist prestashop/ps_facetedsearch >=0 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact We have identified that some psfacetedsearch module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE. This vulnerability impacts - phpunit before 4.8.28 and 5.x before 5.6.3 as reported in CVE-2017-9841 - phpunit = 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers) Patches In the security patch, we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading. Workarounds Users can also simply remove the unwanted vendor/phpunit folder. References https://nvd.nist.gov/vuln/detail/CVE-2017-9841 For more information If you have any questions or comments about this advisory, email us at security@prestashop.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f884-gm86-cg3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-f884-gm86-cg3q Advisory: PrestaShop module ps_facetedsearch might be vulnerable from CVE-2017-9841 IDs: GHSA-f884-gm86-cg3q Record: https://patchnext.com/advisories/ghsa-f884-gm86-cg3q (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/ps_facetedsearch 3.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/ps_facetedsearch: affected < 3.4.1; fixed in 3.4.1 ## Suggested inspection (read-only) - Packagist prestashop/ps_facetedsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/ps_facetedsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f884-gm86-cg3q (GitHub-reviewed advisory GHSA-f884-gm86-cg3q lists affected ranges: Packagist prestashop/ps_facetedsearch >=0 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…