prestashop/ps_facetedsearch: PHP Object Injection in faceted search cache allows unauthenticated RCE
CVE-2026-54159GHSA-m5f5-28qr-9g9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/ps_facetedsearch 4.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/ps_facetedsearch
- Affected
- >= 3.0.0, < 4.0.4
- Fixed in
- 4.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m5f5-28qr-9g9r lists affected ranges: Packagist prestashop/ps_facetedsearch >=3.0.0 <4.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-54159: 0.75% estimated exploitation activity in the next 30 days; percentile 55.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A PHP Object Injection vulnerability affects the PrestaShop module psfacetedsearch. The module rebuilds the selected search filters from the request URL. The value of a slider filter (price or weight) is taken from the URL without sufficient validation, then stored in an internal filter-block cache where it is serialized and later read back with a raw native unserialize(). By crafting that value, an attacker can smuggle a malicious serialized PHP object into the cache. When it is deserialized, a gadget chain writes an arbitrary PHP file inside the module directory, which is then used as a webshell to run commands on the server. Who is impacted Any shop using a vulnerable version of psfacetedsearch that displays a filter template containing a slider filter (price or weight). Exploitation is remote and unauthenticated, a single crafted front-office request is enough, and leads to remote code execution and full compromise of the shop and its server. Affected versions: 3.0.0…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m5f5-28qr-9g9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54159 Advisory: prestashop/ps_facetedsearch: PHP Object Injection in faceted search cache allows unauthenticated RCE IDs: CVE-2026-54159, GHSA-m5f5-28qr-9g9r Record: https://patchnext.com/advisories/cve-2026-54159 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/ps_facetedsearch 4.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/ps_facetedsearch: affected >= 3.0.0, < 4.0.4; fixed in 4.0.4 ## Suggested inspection (read-only) - Packagist prestashop/ps_facetedsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/ps_facetedsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m5f5-28qr-9g9r (GitHub-reviewed advisory GHSA-m5f5-28qr-9g9r lists affected ranges: Packagist prestashop/ps_facetedsearch >=3.0.0 <4.0.4) Commands are suggestions: review each one before running it.
Loading voting…