Skip to content

← Public intelligence

Packagist package

mediawiki/core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

28 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3PackagistPublished

    Mediawiki Improper Privilege Management

    CVE-2018-0503 · GHSA-mhfv-9h99-jwg7

    Affected
    • Packagist mediawiki/core >= 1.27.0, < 1.27.5; >= 1.29.0, < 1.29.3; >= 1.30.0, < 1.30.1; >= 1.31.0, < 1.31.1
    Fixed in
    1.30.11.31.11.29.31.27.5· Vendor fix available
    Issue
    Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.

    Recommended action: Upgrade to 1.31.1, 1.30.1, 1.29.3 or 1.27.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5PackagistPublished

    Mediawiki BotPassword can bypass CentralAuth's account lock

    CVE-2018-0505 · GHSA-5c6w-f4w2-2grp

    Affected
    • Packagist mediawiki/core >= 1.27.0, < 1.27.5; >= 1.29.0, < 1.29.3; >= 1.30.0, < 1.30.1; >= 1.31.0, < 1.31.1
    Fixed in
    1.30.11.31.11.29.31.27.5· Vendor fix available
    Issue
    Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock

    Recommended action: Upgrade to 1.31.1, 1.30.1, 1.29.3 or 1.27.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5PackagistPublished

    Mediawiki information disclosure vulnerability

    CVE-2018-0504 · GHSA-hr8v-f4g2-p66f

    Affected
    • Packagist mediawiki/core >= 1.27.0, < 1.27.5; >= 1.29.0, < 1.29.3; >= 1.30.0, < 1.30.1; >= 1.31.0, < 1.31.1
    Fixed in
    1.30.11.31.11.29.31.27.5· Vendor fix available
    Issue
    Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains an information disclosure flaw in the Special:Redirect/logid

    Recommended action: Upgrade to 1.31.1, 1.30.1, 1.29.3 or 1.27.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →