Skip to content

← Actionable
Medium, CVSS 6.5

Mediawiki BotPassword can bypass CentralAuth's account lock

CVE-2018-0505GHSA-5c6w-f4w2-2grp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.31.1, 1.30.1, 1.29.3, 1.27.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mediawiki/core

    Affected
    >= 1.27.0, < 1.27.5>= 1.29.0, < 1.29.3>= 1.30.0, < 1.30.1>= 1.31.0, < 1.31.1
    Fixed in
    1.30.1, 1.31.1, 1.29.3, 1.27.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2018-0505: 1.97% estimated exploitation activity in the next 30 days; percentile 80.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5c6w-f4w2-2grp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-0505

Advisory: Mediawiki BotPassword can bypass CentralAuth's account lock
IDs: CVE-2018-0505, GHSA-5c6w-f4w2-2grp
Record: https://patchnext.com/advisories/cve-2018-0505 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.31.1, 1.30.1, 1.29.3, 1.27.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/core: affected >= 1.27.0, < 1.27.5; >= 1.29.0, < 1.29.3; >= 1.30.0, < 1.30.1; >= 1.31.0, < 1.31.1; fixed in 1.30.1, 1.31.1, 1.29.3, 1.27.5

## Suggested inspection (read-only)
- Packagist mediawiki/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5c6w-f4w2-2grp (GitHub-reviewed advisory GHSA-5c6w-f4w2-2grp lists affected ranges: Packagist mediawiki/core >=1.27.0 =1.29.0 =1.30.0 =1.31.0 <1.31.1)

Commands are suggestions: review each one before running it.

Loading voting…